Jam Origin

MIDI Guitar & MIDI Bass user forum

MG2 iOS / Syntronik AUv3 issue

Hey,

Anybody else having issues with Syntronik? Whenever I load it in the AUv3 slot in MG2 iOS the MG2 app crashes.

Any ideas?

Cheers,
Luke

Hello MIDI Guitar 2 friends, am I to take it then that this is just an issue affecting me? Anybody got a similar problem or a solution?

I doesn’t crash MG on my ipad. You can try load it in anohter host, and see whether it behaves there. Also make sure no other apps are running, AUv3 often has memory issues, running other apps could make it worse, I don’t know for sure.

Fully operational in all hosts tested (AUM, AB3, APEMATRIX). Only crashes MG2. No other apps running…iPad Pro 10.5”…not sure why it would be having issues…

Actually, it’s crashing on my iPhone too…

sounds more like a graphic issue… pleas try give it another screensize in our pluginmanager

What ratio is yours set to? All seem to crash on my device?

to be honest, I started SSyntronci AU a couple of times to see if it works, but never used it or started it again. I’lll have a look at it the day after tomorrow.

Hey Paul, did you happen to check this? I had a further crash of MG2 unrelated to Syntronik :sob:

didn’t get to it yet.
But what we noticed so far is the following, it might or might not be your problem now:
AUv3 plugins might crash after loading them for the Xth time (each time you open an MG patch the contained AUv3’s arereloaded) Now the number of reloads before crashing is personal to the plugin, it seems to be related with the amount of memory they use. It will also crash in other hosts just as much.
The plugins that we checked had a pattern of about 20 reloads before crashing.
This was before the update to ipados13. Since then the number of reloads before crashing has increased considerably.
There is no mechanism for us to have influence on these kind of crashes, it is all governed by the iOS system itself, we can only wait for iOS updates that fix this basically.

syntronik AUv3 crashes every 5th time I load it here.
(Syntronic 1.6.0, IpadOS13.3, default plugin size, small/embed )
The CPU usage, right top of screen, goes 100%. Clicking the CPU meter, wil lshow you who is doing all the sweating…
As soon as it happens, one can reload the patch. Now it is calm again, for 4 reloads…

Interesting…

Syntronik 1.6 (same default 8:3 window aspect & small/embed window size - I’m on iOS 13.4.1).

Just tried to launch the AUv3 10 times and it crashed every time.

CPU doesn’t take off cos the app simply crashes…

Immediate crashes are most likely not caused by the same vulnerability.
what are your surroundings?
-type of iOS device?
-are any other apps running?
-is the MG patch loaded with other plugins? (please try an otherwise empty patch)

I’ll update to iOS 13.4.1 to rule that out.

Your ipados version 13.4.1 was released without testing…
13.5 should now be better in shape… I’m currently downloading 13.5

From macWorld:
"
Apple released iOS 13.4.1 without a beta test, and then started realeasing beta versions of 13.4.5 that primarily included only bug fixes. On April 29, without ever releasing 13.4.5, Apple released what it calls “beta 3” of iOS 13.5. So, Apple just renamed the usual 13.4.5 release with an upgraded version number as it included more significant features.

Updated 05/20/20: Apple has released the final version of iOS 13.5 to the general public. It includes the first version of the Apple/Google contact tracing API. The release will probably go out to the public this week.
"

iPad Pro 10.5"

No other apps open, also hard reset to ensure no background apps were running.

Tried via various patches…always the same crash.

OK! I’m gonna try to update the iOS 13.5

ok,
Which MG are your running: the last official or the beta?

Updating to 13.5 right now

I only run official iOS versions

ok, We’ll test 13.5, that will gave us a better comparison, and maybe kills the bug in one go.

Updated to 13.5.

Exactly the same outcome here. I’ve opened a completely empty patch; Rescanned plug-ins; attempt to instate Syntronik and BAM! It crashes.

perhaps try a surrounding approach:

  • syntronik standalone = ok?
  • loading Syntronik in Audiobus or AUM = ok? (EDIT: skip this, you allready tested that)
  • loading Primer AUv3 in MG = ok? (Primer is free on appstore)