Jam Origin

>> MIDI Guitar & MIDI Bass user forum

No Devices shown for input


#1

I am trying to install Midiguitar2 on a new Win10 Laptop. I have used this program for a few years, but normally on my Macbook, which works perfectly. I am using a Fastrack Pro interface, When I try to use the program on the new laptop, it recognises the interface for output, but there are no devices shown to select input. there is an ! in the latency box, and 0/ 0 shown as the number. I have installed the license. I have tried re-installing the program but still the same. Am I just being stupid about something simple. ? My laptop does recognise the interface in its audio settings. I have just rechecked that everything still works on my Macbook, only changing over the USB between the computers, Any suggestions are glady welcome.


#2

on windows you need an ASIO driver installed. If your interface doesn’t have its own, use the one from asio4all.com


#3

Thank you Paul. I had forgotten that on a previous Win 7 computer that I used, I had actually downloaded and installed drivers for the interface. I did this again last night, and also the asio4all driver. It now works perfectly on my Win10 Laptop. I can hardly believe it took me so long to realise this was the problem. I found your reference to asio4all in another post on a similar problem and that triggered my memory . Thanks again for taking time to reply. You have been really helpful. I am sure that this thread might help other people with similar problems,
Perhaps Jam Origin could include an ASIO driver in their package so that windows users at least have some sort of starting point.


#4

glad you sorted it out!
Including an asio driver could actually make things worse: maybe there is allready an asio driver installed. And if the manufacturer has a native driver, this one should allways be preferred. Windows and audio allways asks extra attention, no matter what…


#5

I am using a Behringer interface and it only works with the manufacturer’s driver. However, I got a generic Chinese interface which does work with asio.