Jam Origin

MIDI Guitar & MIDI Bass user forum

Running with large buffer sizes

Dear Jam Origin,
I have been your MIDI Guitar for sometime, I have recently used in an Innovation Fair to analyze the noisy soundscape and show the harmonic result. It made the job quite perfectly, I have saved and closed the file, opened a new one, set it exactly the same way, but although it seems receiving the Audio input, it does not generate any MIDI any longer, I tried to download again but your site tells that I have latest version.
Hope it is a problem to be solved easily, great job.
Best,
Tolga

I can not say much about it: are you using the standalone? did you try other patches? have you checked the interface settings?

Dear Paul, after a long time that I could not use, I have changed my laptop, installed and started working, for a while though. Now it stopped again and there is no way it comes back. I have restarted the computer, have not tried to reinstall though.
I am feeding with audio recordings, so there is a quite rich polyphonic signal is getting in. I know this is not the way you designed for but it is the most efficient one working in the market, even for this reason.
Would you suggest anything to do? I am not planning to buy another computer for another couple years :slight_smile:

Dear Paul, that was a quick one, MIDIGuitar2 simply does not work on 2048 buffer, MIDI signal is back even when I reduce to 1024. Just keep that bug (if you would call it, I know people are looking for realtime) on the list :+1:t4:

It won’t work well unless you run at 256 sample buffers or below (at 44/48khz). If we faked it and split up large buffers into smaller ones, all real-time users who forget to set buffer size would have good tracking but huge latency. That would be confusing, and many would mistake MG for causing latency even when it’s just about setting a smaller buffer size.