Jam Origin

MIDI Guitar & MIDI Bass user forum

Strange behaviour in Studio one (SOLVED)

Hi everybody,
I finally decided to set up MG2 , Swam instruments and my TEC breath controller.
Everything works fine ( guitar on audio track, MG2 as insert, swam vst on another track, all midi entry, Breath controller controlling the expression in swam) in real time.But when I want to record the midi, i doesn’t record the midi notes, only the CC datas ( velocities, after touch, bend from MG2 and expression from The TEC controller).If I play back the midi track, no sound.The only way I can record the notes is by selecting MG2 as midi input, but then , as expexted, the TEC has no effect and is not recorded.So I can’t figure out why Notes are not recorded when there is obviously note data comming out because the sound I get is Fine.
Anybody experienced this, or has any clue?
Thank U so much
Mac OS 10.14.6
Studio One 5.2
Swam WW v3

hi Again,
i found it!!! Seems like I needed to post before !!
“All midi input” must be on the swam instrument and “MG2” must be selected as input on the track.
If you do the contrary, it will sound exactly the same, but won’t record the midi notes.
Well, maybe this post will be usezful if someone has the same problem.
Cheers !!!

Good catch! I suggest editing the thread title to show [Solved], so people know that there’s a solution available.

It’s Done.
Thanks for reminding me.