Jam Origin

MIDI Guitar & MIDI Bass user forum

Stuck notes

Why would notes never let go? I have this problem where I’ll be play a synth in Logic Pro-X and randomly it will choose a note to hold forever, until I shut off the synth. Does this with two different interfaces. I’ve tried all the settings relative within the synths and whatever else I can think of. This makes MGII completely unusable. Help?

Its not a common problem. MG will always send out the note-off message of course (unless it thinks that the note is really there), so it seems your system somehow loose midi messages.
Does this happen also if you use the standalone MG?
Are you sure your input signal is all dry/clean and not overdriven?
Does it happen only for some particular notes/pitches, or across the board randomly?

Okay. A couple of things were messed up. First, I had been trying to get Logic to see an expression pedal I had hooked up to the Rocktron MidiXchange foot switch. I had trying various midi learn attempts last night and when I went and checked the controller assignments this morning there about a dozen that were somewhat randomly created, I assume by my midi learn attempts. Some of them had value change numbers that were hundreds of numbers long. I guess that because Logic was not seeing the expression pedal it was pulling values from god knows where. And for as long as I left it in learn mode. I did not expect it to create value changes if it wasn’t seeing the pedal I was manipulating. I deleted all those and things seemed better but not completely. The second thing was that I had each plugin instance ( of two) of MGII set to I/O buffers of 32, the lowest possible. I’m using a very strong new MacBook Pro and it handles that easily normally. But as I was looking closer at the MGII plugin settings I looked at the Interface settings and saw the yellow triangle ! saying that my buffer settings were too high ! Regardless I did change to buffer to 128 as the warning was suggesting and now everything seems completely stable . I’m sure there’s a reason for the lower buffer setting acting so weird?

One funny moment this morning when I tried MGII in stand alone as you suggested. It went haywire. Would not shut up. I was shocked to say the least. Well I never use MGII in stand alone and when I checked the interface settings it had set the input as the MacBook internal mic for some reason! So it created a feedback loop of listening to my monitors and regenerating midi ! But that’s what made go back and check the interface settings on the plugins so at least it got my attention headed in the right direction. Couldn’t believe it.

I just want two add this to this discussion since you mentioned having a clean signal. I have a sort of unusual wet/dry setup. I split my guitar signal right away and send one signal to the front of a combo amp and one side to one of the two inputs on a Zoom Tac-2r interface. I take the effects loop out from the amp and put that into the second input. So one side is super clean but the other side can be quite distorted at times. Then the clean side outputs to a clean amp and speaker and the effects loop side goes back to the effects loop return on the combo. So one amp is always completely clean but the other at times can be very not clean. I really like having the combination of dirty and clean going into stereo effects and keeping them separate. That has not been a problem as far as I can tell. But getting an expression pedal to work has been impossible for me to figure out. I remember you saying that Logic has certain limitations in that regard when trying to control soft synths. I was trying to duplicate a setup I saw on YouTube where a guy was controlling a parameter within the Alchemy synth. Seemed to work just fine for him. Logic now has a midi effect plugin called the Modifier. In it’s setting you can choose the event to control from a drop down list it generates for the instrument you have in the track. Or you can have it learn the action you want by manipulating that control in the synth. And you can choose the control or have it learn the controller. That’s what I was trying to employ last night. Easy enough to learn the movement I wanted in the synth but was never able to get it to see the expression pedal (Roland EV-5). I had given up on any of this with my old MacBook but now I have a much stronger Mac and have finally started to to look into performing with it. This would be pretty important to have if I’m ever going to get there. Any suggestions or thoughts would be much appreciated. Thanks.

Not sure if it’s related, but occasionally I used to get a stuck note or two when using Sampletank 2 inside Samplitude DAW (Windows PC). I never get this problem with other VSTi’s. I believe it occured when the processor got overloaded, so these days I tend to limit number of Sampletank voices, and/or make sure I’m not overloading the processor - not had a problem recently since doing this.

Oh well, it’s not fixed. I spent several hours playing with the setup to see if it would hold up. After a while it started holding notes again. Everything is set just as I described before. I added a different Alchemy synth is all. So two Alchemy synths and one Sampler synth and one Retro Synth. I can’t even turn the note off at all in the Alchemy synths any more like I can in the others by turning off the synth plugin in the track. I mean I can turn it off but as soon as I turn the synth back on in Alchemy the note is still ringing. I had the impression that holding a note for longer than a few seconds might be triggering the stuckedness. Seems true. I tried counting the old 1-100-2-100, etc and they all seemed okay up to 3-4 seconds but any longer and they stuck.I made a couple of short videos of my screen to show what a couple of the synths show in their setting pages. You can see the note ringing in the track levels. But also notice that in Alchemy the first oscillator is ringing. And in the Retro Synth the Vibrato is pulsing away. I cannot figure the source of these signals . Can’t figure out how to upload the vids but you get the idea.

Okay, post script. Just as I was shutting down I thought I should reboot and see if things improved. It did. Couldn’t get a note to stick on any track no matter how hard I tried. I need to think about this. Not sure what it means. Thoughts? Thanks.

And still. No help from Apple. No help from the community. No help on any forums. So I guess yet again my dream of performing with Logic remains unattainable. Played all day again and was fine, until it wasn’t. For whatever reason MGII and Logic are not stable enough to perform with. Recording sure. But performing no way.

Sorry, but I’m out of ideas… its not something we can reproduce and so the best i can do is to imagine what could be happening.

I think its unlikely that your MacBook is overloaded or drops MIDI messages. Which Macbook do you use? and which MacOSX version?

It might be that your interface somehow leaks/feedback a little bit of its analog output channel into its analog input channel and then MG will detect that as a sustained pitch.

Otherwise try using MG standalone instead of the MG AU with Logic and enable the MIDI Output. It should route automatically into Logic. Does the same thing happen?

I tried it again in stand alone and it always seems fine in that mode. Noodled around for about an hour then switched from my Zoom Tac-2r to my Motu 828x. Still in stand alone and still good. Played for a while as plugins and not a problem, so far. Going to keep it on for a while longer to see if that holds up. If it does then maybe you’re right about the Zoom interface having a problem.

And I’ve been playing for the last two hours with the Zoom using MG II as plugins and it’s perfect . So how many hours of use before I can trust it? Kind of maddening. I did notice that with several of the synths I can play a note and let it ring until it dies out naturally on the guitar, to the point where it can’t be generating a signal. And yet the synths will continue until I put my hand on the strings. I would prefer, and I would think, that the synths die out. There must something in the general midi settings that is letting them go on and on. But darned if I know what.