Ableton 11.2 Crash

Hi @pasha. I’ll include your crash-description in any (hopefully) future discussion with Abelton if it is ok with you? I have both Intel and Silicon Macs. I use Abelton 11.2.5 with my Studio M1, and 11.1.6 on my old iMac , as well as on my MBP 2019. Right now, I have no issues, except perhaps a tardiness to the 11.2.5 setup. For any case where I run into trouble with an old project not opening correctly, I “wash” it in any of the older computers:i.e. airdrop it into an old computer-open-save-airdrop back.

Ok for me. Do you want the crash file to be added here?

1 Like

No, not yet anyway. It is more of a report on a few different experiences at this point. But I’ll reach out if more is asked for. :handshake:

I have news : Ableton Support answered with some suggestion to try.

  1. Upgraded all plugins to latest versions (MG was 2.2.1)
  2. Deselected the MIDI sync where needed (I had the same interface with Sync selected for both IN and OUT)
  3. Created a new Live Set from scratch
  4. Played for a couple of hours
  5. Used the ‘offending’ plugin, likely Jamorigin MIDI Guitar 2
  6. Saved the Live Set
  7. Opening the Live Set got beach ball of death
  8. Crash

I have been able to drag and drop clips and devices from the offending project (step 6) in the Live Browser into a new project without JamOrigin’s plugin (AUV2 Version) and it did work. I could save and open.
So far my findings are pointing to JamOrigin’s plugin (AUV2 Version) Midi Guitar 2 as the responsible of the crash but it might be something in Live 11.2.5

Hopefully JamOrigin and Ableton will solve it. MG2 it’s very important to me and Live is my only DAW.

Have a nice Halloween Night.

Thanks I will try that.

Just installed Live 11.2.6 and Older projects crashing with Midi Guitar under 11.2.5 are now loading properly.
Still in the early test but looking good.

1 Like

Release notes are pointing to something familiar - downloading 11.2.6 now.

Fixed a regression that caused certain AU and VST2 plug-ins to load with incorrect parameter values (and sometimes fail to pass audio) when loading a Live Set.


Tested with all projects that were crashing Live since 11.2
Version 11.2.6 solved my issues.

Ableton support also reached back to me yesterday asking to validate the new version.
They have been great at following up on the issue. Case closed from my point of view.


I will test tonight then report

After installation of 11.2.6 I was able to load the Projects that were crashing, no problems with MG2. So far it seems solved for me. More on this in the next days when I will go through extensive testing.

Although 11.2.6 didn’t solve ALL my issues, at least I don’t get any crashes with any MG2 projects anymore. (I still have issues with using Reason as a plugin in Live though. In 11.2.5. it just wouldn’t open. Now it does, but there is some annoying flickering window UI issue to sort out still).

I am glad however that Abelton came out with this update/fix so quickly. Let’s hope it was the solution to all MG2 related issues at least!