Jam Origin

>> MIDI Guitar & MIDI Bass user forum

Bends & Legato don't translate to recorded MIDI? (help!)

Hey everyone, I’m using the latest version of MIDI Guitar as a plugin in Logic (I followed Jam Origin’s guide to using the plugin in Logic, using a separate track as MIDI input and all that) and it works like a charm, what an amazing invention - until I tried recording with it.

My desired synth part has legatos and bends, and so I enabled those options on in the plugin. When just playing along and even during recording, everything sounds as it should. Once the part has been recorded however, I played it back and everything’s back to sounding like a piano (no legato or bends). I’ve also noticed that there are no bend or legato markers in the piano roll.

Is there a fix for this? Or is this just an inherent flaw? Thanks again everyone!

There are in standard midi no polyphonic bends and no polyphonic legatos.
These options are only supported in monophonic synths.
Only in MPE synths polyphonic legato and bends are supported, but we currently do not support that.
Bends often do work in polyphonic synths and samplers, but will detune all voices. This is why MG will only create bends when 1 tone is sounding.

If it sounds has it should this means that it’s generating correctly the midi events.
If after that the recorded events are not the same then you maybe have some midi filter?

I don’t think you get what I’m saying … as I said when I’m just noodling around and even when I’m tracking the legatos are there. It’s just that when it’s all said and done and I play my recording back, it’s not.

what’s a midi filter? how do I turn it off?

The midi filter in Logic is adaptable via menu Record / recording settings / section:midi / tab:input filter

I have nothing checked, so that shouldn’t be the issue …

if the synth on the instrument track is doing the right thing, there is no way that the recording should sound different imho.
If you have other instrument tracks, maybe one of them is monitoring alongt, and on playback that synth is not recorded, so you hear something different.

I’m running into a similar situation.
I’m using Presonus Studio One Pro, version 4.5 (current version updates completed)
When previewing the instrument, in this case Presence, I can see the image of the key board,
bend wheel, etc. I can see movement in the bend wheel and hear note bends, so it seems as though it’s getting all the midi signals to it, but as soon as I hit play or record all the bend data seems to get disabled. Bend wheel on plugin image freezes. Note data is still getting through and it is recording midi notes, but nothing on bend data.
As soon as I stop play or record, the bend date gets re-enabled.
Not sure what’s going on here.

must be a midi filter in S1. As far as I can see, midi fitlering is done on midi port level: (in preferences / external devices). But I can’t see where the difference between playback and recording comes from. I’m lookin at S1 Prime here now.
Do you use the preferred setup with the MG vst on one track and instrument on other track?

At this point I’m pretty much satisfied that it’s a bug in S1.
I’ve tested this by setting up 4 tracks.
Track 1: audio track with MG as plugin
Track 2: Instrument track using MG as input device routed from track 1 (MIDI controller), Virtual instrument to generate sound
Track 3: Instrument track using MG as input as well as instrument
Track 4: Audio track using instrument from track 2 as audio input.

The results of this test when recording on all of these track simultaneously (except track1) is as follows:

Track 2 records note data as well as velocity data but does not capture bend data.
Track 3 records all the data. Note, velocity and bend
Track 4 records audio from track 2, and I can hear the note being bent.

The only conclusion here is that there’s something in S1 that’s blocking the bend data from a virtual controller. (it will capture bend data from a hardware controller like a keyboard with bend wheel)

**Quick note on S1 prime is that the prime and artist versions don’t support 3rd party VST’s.