Jam Origin

MIDI Guitar & MIDI Bass user forum

Cannot invoke Midi Guitar Out or Virtual Midi as input in Cubasis 3

Being fairly new to midi, I’m hoping someone can provide detailed step by step instructions on how to run Midi Guitar 2 within Cubasis 3. It will be much appreciated.

I’m running iPad Pro, iOS 13.4.1, with Scarlett 2i4

Things tried:

I bought all the MG2 plugins

I set MG2 setting to External Midi Output > Virtual Midi

Run Cubasis 3 (as well as Cubasis 3Le) and have Setup > Audio > Background Audio = On
In the Cubasis 3 midi track Routing Input I choose ‘Midi Guitar Out” from The list dialog, but it is not accepted, and reverts back to “No MIDI Input”

Note: Virtual Midi input option does not show in the list in Cubasis 3, but does show as an option in Cubasis 2Le.

With the setting the same in Cubasis 2Le, I can choose “Midi Guitar Out” as well as “Virtual Midi” in the list dialog.

Thanks in advance,

Dave

I have tested just the CB3 demosong, selected a midi track and it immediately played along with MG. I didn’t touch anything, it automatically recognised the midi input.

I took a closer look: CB3 does indeed not allow to select MIDI Guitar out. But works anyway, even if no input is selected… strange bug.

Doesn’t work for me at all. I even tried on another older iPad Pro. Did I do something wrong in my steps? MG2 works without touching in Cubasis 2Le.

please doublecheck the midi output midi fx in MG.
Click on it, and choose “virtual midi” for output.
(Cubasis 3 doesnt work for output here)

Yes. I checked that many times. I made sure to select Virtual Midi. I followed the exact steps in the Jam Origin video for using with Garage Band—which works fine.

Thanks

I got CB3.03 LE running here. What is your version?

Same. Tried the demo 3.03 as well.

ok, and in the demo it also didnt work?

No, unfortunately it did not. Tried on another iPad as well. Unplug and plugged in to Scarlett.

there is something fishy here. Are you running on an otherwise empty system? no other apps running excpet CB3 and MG?

All other apps are closed. Brand new iPad Pro, latest updates 13.4.1. I closed all the background apps except MG2 and CU3.03

one thing that your ipad and mine have in common: CB is having a bug. I select “no midi input” in CB. and then it works, if I set MG to virtual midi.
that is not correct, and it is highly unlikely that it is MG’s fault. It is not a known bug according to Steinberg.
And: “all inputs” also works! I notice know. it makes not much sense, I know…

I don’t get any sound if I choose the ‘midi guitar out‘ though. Also CU3 doesn’t show Virtual Midi as in Virtual 2Le. So at least 2 differences in behavior.

I assume you are the developer? What are my next steps?

MG’s “virtual midi” output port presents itself to other apps as “MIDI Guitar out”.
the virtual midi input port “Cubasis LE 3” is not selectable in CB, allthough it presents itself to MG for input.
Maybe we should push some button at Steinberg’s

I still want to rule out if I’ve done anything wrong, it’s kind of driving me nuts. Do you have any concrete instructions on how I can start from the beginning. I will delete both apps and restart my iPad and try again. But I would appreciate some simple instructions to rule out any user error on my part.

no, you havent done anything wrong. CB behaviour here is faulty, and it is faulty over there, with differnet outcomes. Most likely the CB popup menu for midi input select has a fault in it, it oesnt choose what you think you click.
I have got 2 midi sources to choose from, and then I get my result. You have probable 1 midi srouce and then it doesnt work at all.
If you got some other midi device, plug it in, to have 2 midi sources. that way we can say we have found the bug.

It just so happens I do have too many devices. I am currently using the scarlet, but I also have a Apogee JAM that I will plug in now. Standby

try to get 2 midi input sources, that way, chances are you got the same buggy situation as me, but you can then work…

Interesting. Works now. That’s a weird bug, I select midi out, the same as you now, even though it doesn’t show as the choice I’m getting output from MG2 now. Thanks!

Do you mind pinging Steinberg if you believe this is their bug? I think he would hold more sway than me.

Thank you for your help I really appreciate it

1 Like