Jam Origin

MIDI Guitar & MIDI Bass user forum

Crash with Cakewalk by BL with MG2 and VST3 Amplesound

Not a rely serious problem because there is a solution. But, I’m just wondering if anyone else has this problem. I notice I get a crash on playback with any two of the Ample sound VST3 plugins I have. I check from time to time with new releases of Cakewalk versions and it doesn’t seem to correct the problem. Replacing the VST3 for the VST2 version of the same plugin works just fine, so that’s what I use (MG2 is a VST2 as well). Just wondering if this is normal behavior. I haven’t tried with other synth plugin yet.

1 Like

I recall others having this problem in the past. There is some compatibility issue among Ample VST3s and MG. I believe we have addressed it for the next updates.

1 Like

Thanks JamO. I will check for the update.

1 Like

@cidmrgs,

When Cakewalk by Bandlab (CbB) crashes CbB creates a mini dump file that provides a lot of detail about what resources were in use and what unexpected condition caused the crash. Mini dump files saved from Cakewalk are stored as timestamped files with a .dmp extension in the following folder: %AppData%\Cakewalk\Cakewalk Core\Minidumps. Note that if the crash was in a plugin the file may be in this folder instead: %AppData%\Cakewalk\Cakewalk Core\Minidumps\Plugins. You can normally identify the correct mini dump file by its timestamp if you know when the crash occurred.

Sometimes mini dumps are very large files so you may want to store the file in cloud storage and provide a link to the file. While Jam Origin has a good idea what is causing the crash, that might not always be the case. Or it may turn out that Amplesound or Cakewalk by Bandlab also has an issue that needs to be addressed.

Hi. Thanks for the tips. That led me to try something.

I did some test with a fresh and basic session. I don’t think the crash is caused by MG2. I think this has something to do with Controller or pitch bend data or quantity of, somehow.

A good quantity of pitch bend data appears to be recorded with MG2, and I do get a crash on playback with the Ample Sound VST3 (again - not a problem with VST2 version).

I deleted the input with MG2 and tried to record lots of pitch bend and modulation with my keyboard controller. Same thing, it crashes on playback.

Conclusion is : It’s not MG2 that is involved. Might be the plugin instrument.

Thanks for leading me in a direction.

1 Like

@cldmrqs, I’m glad the information I gave inspired you to investigate more. I hope you have shared your test results with Amplesound.

I’m looking into it. Thanks again for the input.

1 Like

New here. I have recently updated my 3 Amplesound acoustic guitars v3s to latest version 3 updates . They all crash my Cakewalk by BL in playback. Stop and start. Also in piano roll. For a while I found a temp fix by turning off built in FX, but its crashing again now. Have resorted to using the free version of Martin. Very frustrating.

Same problem here with their bass. Running the vst3 version crashes. Running the vst2 works perfect. I’m pretty sure it’s an issue with Ample Sound.

@DavidOH Welcome to the forum. It’s a shame you are having issues using the V3 Martin acoustic and @cldmrqs is having trouble using V3 of one of Amplesound’s bass VSTs.

In both instances you should visit the Amplesound forum and work with them to resolve the issue.

The good news is I’ve heard Amplesound is responsive to resolve customer issues.

Cakewalk by BandLab update v2021.04 early release has a fix for the VST3 crash. Both of you may want to download the early release to test if it resolves your issue.

From the relase notes: fix for AmpleSound VST3 plug-ins crash when trying to play attached MIDI file.

Cakewalk by BandLab V2021.04 early release announcement thread