Demo Only Guitar Sound (Mac, UA Apollo)

I downloaded the demo, but all I get is guitar sound, nothing registering on the velocity meter.
I read other posts where the solution was to go to System Prefs/Security and Privacy and allow the mic to be used, but in my System Prefs, the mic is not available to select.
I’m using Universal Audio Apollo and Mac Pro running El Capitan.
Both Input and Output show UA Apollo, In Channel 1, Out 1/2, so MIDI Guitar sees my interface.

Your help would be greatly appreciated.
Thank you,

Maybe your interface has some kind of “direct/monitoring” option set?

Thanks for your reply.
The Apollo interface has its own Console app which is a virtual mixing board.
I have the option of changing the source path from Mix to heaphone 1 or 2, and can que the output to paired tracks, but that didn’t solve the problem in this case. Maybe Midi Guitar is not compatible with UA Apollo.
Thanks again,

  • Please check whether our app has macos microphone permission:
    you need to give “microphone permission” to the app. see your mac’s system preferences, security & privacy, choose “microphone” in left column, check MIDI Guitar 2 the right column.

Microphone is not available in the left side bar (or anywhere) in system preferences, security & privacy.

ok, sorry, you allready mentioend that. Microphone securtiy is introduced with Mojave, not with El Capatian.
if I understand correctly the appollo has a complicated routing system, have you checked whether you have set up the routing correctly for core audio use?
I remember someone having this same problem.

Thanks again for your reply.
With UA Apollo, there is no complicated set up, it is the audio interface. Its basically plug in and play, as long as you’ve got the UA software installed.
I could go into System Prefs Sound and choose a Line In, Digital In or Protools Aggregate, but then I would have no interface.

as far as I can see here, there is a matrix to assign the hardware in/out channels to the core audio channels. You might want to double check that.

That video explains how to set up and change the routing of I/O between Apollo and your DAW, and does not mention core audio. Midi Guitar 2 has shown Apollo as input and output, Channel Input 1, Channel Output 1/2 the whole time I’ve had the demo, so it clearly sees the Apollo. But still no midi velocity. I searched for more info, including on the UA website but could not have this issue address.
Thanks again.

have you tried twiddling the samplerate/buffersize?