Essetial on VST/2.21 on Standalone

Hi everyone, I’m new here and new with the purchased midi guitar 2
My question: in the VST, using Cubase 11 I see that I have version Essential, but in the standalone I have version 2.2.1: is that right?
I’m still on Mojave 10.14.6 (don’t want to upgrade that) and downloaded the corresponding MG2 for that; maybe it has to do with that?

Another question; I’m on 64 bit in Cubase and suprisingly happy that I could use all my 32 bit apps in the standalone (not in Cubase) so is there a workaround to use the 32 bit app in Cubase too?
(when I scan my apps in MG2 in Cubase, I get the ever lastin beachball, untill I force quit)

Thanks in advance!

In not sure what is “Essential”. It sounds like you have a very old MG VST in your VST folder. Make sure you delete any old versions and get the latest MG (version 2.2.1) on and install the VST.

If your Cubase is 64bit, it should find the 64bit MG VST, when you have it installed in the Steinberg VST folder for 64 bit plugins (or in any folder where Cubase looks for your VSTs).

If the Cubase scan crash, most likely you have some dodgy old plugins.

Tnx for the responce JamO…!

You were right; there was an old MG from 2014 in my VST list (together with MG2)
So I removed all MG/MG2 related items and installed MG2 again. (2.2.1)
When I open Cubase now, it’s in the insert-list, but when I click it, nothing happens and MG2 doesn’t open.
When I look in the plugin manager, I can find MG2, but in the FX library list it’s greyed out.

So, I’ve put back the old MG VST and it opens again! (in the VST list, it’s next to the VST MG2!)
It shows MidiGuitar Essential 0.9.3 Beta!
Very strange, how is this possible?!

I’m using MIDIGuitar 2 with Cubase 11. I don’t know if bit app are a problem? All the VST are Steinberg so I don’t get an Essential 0,0,9,3 in a standalone. Are your VST’s Mojave? I would read Steinberg manual online about VST’s from other developers and see what they say? Perhaps see: Installing and Managing VST Plug-ins ( and go from there?

Well, I have hundreds of apps from other manufacturers: all work well…
Yes Mojave
In standalone I have 2.2.1
In Cubase I have the 0.9…(tho the app looks quite similar as the standalone!)

When I click on the vst icon (which goes in the vst folder) with option-I, I see that it’s from 2017; is that right?

Yes, I guess I’ll have to dive in tomorrow and start from scratch again…

Solved! for the ones who have the same issue: I had more than one FX Library lists in my VST plugin manager, so I had to move the MG2 app in the recent FX Library list; now it works and I have the latetst MG2 (2.2.1) in Cubase (after I deleting all old MG1 items)

Tnx everyone for your imput!


1 Like