Facing issue with notes sustaining even after turning the Guitar. volume down

Hello, I recently started using Midi Guitar 2 with Ableton Live and I can’t fix the problem with sustaining notes that keeps playing even when I turn my guitar’s volume down, Can anyone help please?


Hi Joy! Welcome here, to begin with. Now, how do you mean “keep playing”, and what are the circumstances? Macor PC? Are you using MG2 in standalone mode, or in plugin mode with Abelton? What instrument are you using, that sounds even after you’ve turned your volume down? I am sure we will be able to help you, if we just can get to know a little more. :grinning::handshake:

Thank you for the quick response, I’m using MG2 in plugin mode with Ableton (MacBook Pro) using Serum VST (it does the same with all VSTs as well)

Ok, great! I have Mac and Serum as well, so lets test. Could you take a picture of your MIDI Guitar settings perhaps? Something like this:

Sure here’s a screenshot :slight_smile:

Great, nothing strange there! So what preset are you having trouble with in Serum? I guess it isn’t all of them?

Any preset I use in any VST (not only serum), if I play a note and turn the volume down or stop playing, the note keeps on playing with a long sustain.
I took a small video, how can I share it with you?

Interesting! You can send it to my mail? lofileif@yahoo.se

I had a similar issue and was able to resolve it by increasing the input volume on my guitar and my Audio controller.

I think that when the volume on the input is HIGHER, it’s easier for the software to tell whether a note is being played/not being played. If the overall input volume is lower, there is a smaller dynamic range for the software to sort through, resulting in ‘unlimited sustain’ on many notes. As soon as I got the inputs on my guitar and my audio controller set up properly, my notes having ‘infinite sustain’ went away pretty quickly.

What’s your chain, are you sending any other midi signals to serum? You can also use Ableton’s midi monitor to see if what messages are being sent

I emailed you the video, thank you.

Thank you, I tried it and it didn’t work :confused:

Only my guitar! Nothing else.

Yes, I just had look. And there is definitely something strange in the way your tone behaves at 00.04. I can hear a little pause there, before it continues. Are you playing through a pedal or do you have your guitar connected directly to you audio interface?

Here is how this works approximately: your synth is responding to incoming MIDI messages with actions dictated by the type of message. So a NOTE ON message would strart a note playing, and a NOTE OFF message stop that same note. You obviously have a lot of other information in these messages as well, actual pitches and velocities and stuff, but lets start with NOTE ON and OFF.

MIDI Guitar translate incoming audio to MIDI by recognizing what pitch it is, and send out a MIDI message accordingly. When I stop that note from ringing on my guitar, never mind how (I can mute the string, lift my finger, or turn down the volume) MG2 will send a MIDI OFF message, telling the synth to stop playing that note. If you look in MG2:s MIDI Monitor, it will look so,mething like this:

Here I am told that MG2 has sent a A1, velocity 21 message on MIDI channel 1. But since the MIDI Guitar software can’t know about when we lift our finger off our string, or stuff like that, it sends the NOTE OFF message when (and only when) it gets a velocity = 0 value for that note. And this is why it is particularly important to stop your notes from ringing properly. Now, turning down the volume on your guitar would certainly do the job in any standard case, but we probably have something else involved here. It could be a reverb on the incoming guitar tone, that won’t disappear as you turn your guitar volume down. It could be some electric interference (less likely though) , and it could be you have a sustain pedal hooked up to your computer in the ON position, telling your Synth to keep playing. I don’t know yet. Try opening MIDI MONITOR in both MG2 and Abelton (on the synth track) hit and stop a note, and see if you get the same messages in both software. It should look something like this in Abelton:
Skärmavbild 2022-11-01 kl. 10.21.01
But first, NO pedals or effects, right?

Oh yeah, skip any LEGATO stuff to begin with. I just had that to see if there was something in your particular setup. DISABLED in the Legato slot!

Thanks for all the explanation, I removed the pedal which was linked but in bypass mode, it worked :slight_smile:

1 Like

Glad to hear it worked! :+1: