Getting Midi Guitar 2 output as MIDI data instead of wav in Reaper: solved! (I believe.)

I tried all the forum instructions I could search for, watched the videos here, found instructions elsewhere, and still went to bed last night frustrated that I couldn’t get it working. Hopefully this will help some other poor soul.

Woke up this morning, ready to be frustrated again. I had the MIDI monitor up, and knew MG2 was sending MIDI data – I just could not get it to work.

So I started fresh, and it may really be this simple – in fact, my problem might have been assuming I’d have to adjust a ton of stuff in both MG2 and Reaper to get it working.

So you’ve got a track with MG2 as FX, and you’ve got it armed. Assuming your guitar is running through an interface via send 1 or send 1/2 – LEAVE THAT SETTING ALONE. I probably wasted so much time because I thought it or something in MG2 needed fixing. Instead, go to the record settings (should look a lot like the send input button) and change it from “in” to “output: MIDI.” Now your send button should have changed to say “Send 1: Record MIDI.” Voila! MIDI output. Like the option says. Facepalm.

Even if I hadn’t figured this out, MG2 would be worth it for me. But as we all know, copying, editing, and manipulating MIDI tracks is fun, and a lot easier way to pile on – er, layer – the instruments than rerecording each part. Hope this helps someone.