GM2 worked exactly once with my iPad, now it won't generate midi. Do i need to return your product?

GM2 worked exactly once with my iPad, now it won’t generate midi. Do i need to return your product? Signal is strong, but now it just doesn’t work.

Hello Mike, welcome here :slightly_smiling_face:

MG works correctly with an iPad.
Moreover, if it worked once on yours, it means that something has changed in your iPad or the settings: update or installation of a program causing a change of rights, etc…

Have you looked for more information in this forum? Type “iPad” in the search field to possibly find a clue to this change.

If you do not find anything, you will need to provide more information about your configuration: version of the device, OS, etc.

Its had to guess from the description, but maybe run it inside a host and didn’t buy the hosting IAP?

Apple dont let us developers have any control over payments, so the only way to is to ask Apple.

Hi Herold,

I have a 9th gen iPad, running IOS 16.5.1, using a 3rd gen Scarlett Solo w/USB C camera adapter for the guitar interface. I downloaded MG2 a couple of months ago and tried using it w/iRig2 but the latency was horrible. Yesterday I went out and purchased the Scarlett and camera adapter. All worked great for one session. I turned everything off and back on aagain a couple of hours later and although MG2 was still registering plenty of signal from my guitar, no midi notes were showing. I tried using the built-in mic on the iPad with the same results. I can play the midi instruments w/the keyboard built-in to the app, but the audio to midi conversion stopped working. I’ve unplugged, rebooted and no change. I looked on the forum and found this issue going back to 2019, but I was unclear if it had ever been fixed. I saw something about buffer size, but mine appears to be locked at 1024. Any help is appreciated. I just laid out about $300 total for this setup and I’m dying to use it. I’m also using iSymphonic as a plugin.

I’m not sure what your reply means. I’m just running the purchsed apps on a 9th gen iPad - no proxies that I’m aware of. Please read my reply to Herold.

As I am a Windows user, I’m unfortunately not going to be able to help you much, and I hope that an MG user on iPad will drop by and be able to help you.

You say that the buffer size is blocked at 1024 samples: I do not understand the term “blocked”: on Windows, this is set in the audio interface driver (Scarlett for you) and you should be able to set it to 256 samples (44.1 kHz). At a higher value, latency will be too high and annoying to play.

As for the rest, once again, I am sorry I can not help you, but as I have already said: if everything worked properly once, there is something that has been changed. For example, have you checked that it’s not a problem of permissions/privacy, and so on.

Are you running the MG2 in standalone mode or as a plugin in a DAW on your iPad? I am interested in how you end up with a buffer size of 1024 there. It should be locked to 256, I think.

If the iRig2 solution worked before, did you try it again (to rule out any issues with the new gear)?

And, how do you identify incoming audio and the lack of outgoing MIDI? Are you looking at the noise gate meter and the Velocity window for incoming audio? You should be able to see this even without any audion interface, just using your built in mic.

If you click on the MIDI OUTPUT in the MIDI FX slot, you get the translated MIDI note messages in the inspector to the right. But you won’t get any MIDI out of MG2 until you choose from the MIDI OUTPUT options list of course.

What does this view look like for you if you try this in standalone mode?

The buffersize at 1024 is the problem. Not sure how it ends up there.
Please try cold reboot the ipad.
If everything fails, try loading it in a host (something like AUM or Garageband) - then you can set the buffersize in the host.


Tried for an hour to get Garageband to recognize MG2, but it always just says “App not available at this time”. I have the app set to virtual midi and have followed all other instructions on the web. How do I get my money back for this product?

One final thought: Apple did a security update, 16.5.1, about the time I was starting everything up a second time. The app didn’t work after that. Could Apple have nuked your app?

Just checked mine with 16.5.1, with no problem. So that is probably not it!

It happened before that we were nuked by an iOS update, but this time I haven’t seen other evidence.

Refunds: Request a refund for apps or content that you bought from Apple - Apple Support

You could check in iOS settings whether the microphone permission is given for MIDI Guitar. without that permission it wont work.

Thank you Paul. I’ve checked and the microphone permission is on. I have no doubt that this is working for other people, but I’m sincerely disappointed that neither Apple or Jam Origin could figure out a fix for me. I’m sure I’m not the only one in the world who’s had this issue. BTW, my day job is technical writer and testing specialist for a software & hardware engineering company - I doing beta testing for a living. My co-workers who are senior engineers can’t fix this issue either. Frankly, I think my version of the app is corrupted - and it may not even be their fault - but Jam Origin won’t offer me any options to replace or fix it. Like I said, I’m just very disappointed, because all I wanted to do was make music. This whole experience leaves me very, very sad. And I’m out a couple hundred bucks for my trouble.

have you tried connecting the guitar to the other input channel?
have you connected a powersupply to the camerakit adapter?