Hanging Notes in MainStage 3

Has anyone had a problem in MainStage 3 w/ MG2 & hanging notes? I’ll play a synth pad/patch for 30-60 seconds and within that time I’ll get a note that will just sustain indefinitely. The only way to cancel it is by pressing the space bar. This could be a large annoyance for performing live. Any suggestions or fixes?

not a known issue. Please check whether this happens with all synths or just specific ones. Also check you use the simplest possible setup like shown here: https://www.jamorigin.com/docs/daw/#toggle-id-5

Loading MG on different levels in Mainstage (concert, song, scene) will lead to having multiple instances of MG running at the same time, with confusing MIDI You should take care to only have 1 MG running, the proposed method in the vid is the simplest. Mainstage has no true midi routing, that is the reason for this caution.

Yep, I followed those instructions specifically for running MG on MainStage.

At first, the hanging notes were ridiculous, I couldn’t even play one or two notes before having them all ring out, but then realized it was because I had GarageBand open. Thought that would’ve fixed the problem, but eventually it started to happen again on a lesser scale. 1 in every maybe 50-60 notes will sustain indefinitely. I took extra caution to only have one MG running. It happens with all of the virtual instruments, but seems to happen quicker and more frequently when I use a synth pad or when playing chords. I tried to create a new session, and at first it was working. I was using the same pad that was giving me trouble, but this time I had 0 issues. I began to build my setup back and program more patches back into the session, but then it started to happen again. The other thing I tried was adjusting the buffer size, which seemed to improve it at first, but eventually gave out. Could it be a storage issue with my mac? Maybe a technical issue of either my Roland UM-ONE or Behringer FCB1010 not properly sending the NoteOff signal?

you should check whether the audioinput is on loopback, that would cause the same error pattern . likely to be found in interface manager or mixer.
A loopback function allows to record the outputsignal of your interface instead of the input signal (your guitar).

Just did a little more trial and error. When I took out the Roland UM-ONE/Behringer FCB1010 and just went the MG2 straight with MS3 there were no hanging notes and I played for awhile. When I plugged in the footcontroller again, they came back. One thing which is weird is that I programmed two different synth patches, one is just a synth pad, the other is that synth pad but with a synth lead on top of it, for some reason when a hanging note gets stuck if I just switch to the other patch about 95% of the time it will let go of the note. Not sure why that is the case. When using the foot controller with just straight guitar effects like Phaser/Flanger built into MS3, it operates fine. The foot controller operates fine when using the standalone version of MG2. This problem is just very specific to using MS3 virtual instruments, MG2, and the Behringer FCB1010 all at the same time.

Is the loopback function a setting in MainStage? I don’t think the focusrite interface is the problem because it worked fine without the foot controller.

let’s concentrate on your fcb1010. have you connected both midi in and out to your fcb1010? start with only using the midi out of it, so only 1 midicable connected.

Yep, I always only use the midi out.

ok, so there is no problem when the FCB1010 is not connected, at no time?
do you only use the programchanges of the FC1010? what cc’s do the 2 pedals send?

When the FCB1010 is not connected, MainStage + MG2 run fine. But the FCB1010 also runs fine with standalone MG2 without Mainstage.

I’ve been using Bank 00 PC 01 & 02 on the FCB1010 to start. Which is equivalent to Bank 1 PC 001 & 002 on MainStage.

I should also mention … I tried to see if I would get any hanging notes when doing the “musical typing” thing with everything connected, and I did not get any hanging notes. I even used the Behringer to switch between patches, and everything worked perfectly. There is some interruption going on between these four devices (MainStage, MG2, Roland UM-ONE, FCB1010)

More trial and error today.

Deleted MS3 and re-installed it with no luck. Changed the CC#'s and no luck. Only thing that seems to work is the note will sometimes let go if I switch to another patch.

I just discovered maybe it’s not related to the FCB1010? I was fooling around with the standalone MG2 (not even w/ MS3) and kept getting hanging notes on the “Bassline Playalong” patch every time I hit a low E note.

Edit: I think I can confirm that the UM-One and the FCB1010 are innocent in all of this. After completely taking them out of the equation, and adding 8 different patches to MainStage, I am still getting hanging notes. I tried using a different patch cable, but that did not change anything. I also tried using MG2 on my HP Laptop w/ the focusrite, and I still get that low “E” hanging note on the “Bassline Playalong” patch. So it doesn’t appear to be a computer problem either. If it IS the Focusrite Scarlett that is the culprit, what can I adjust to stop this from happening?

the bassline script is supposed to keep the last bass note hanging. So that is solved: Dont use that script if you dont want that.

Oh ok, I’m still at a loss then.

Upon reading these forum’s I think it could have to do with the USB 3.0 port. Going to order a 2.0 hub, and see if that solves the issue.


Surely that would only help if you had MIDI note on/off data passing through the USB?
You’re just using MG2 for your notes, right?

I occasionally get stuck notes. Seems to be lowest note of a chord. Possibly caused by a sympathetic resonance. Muting the strings won’t kill it, but finding and replaying the note will.