Jam Origin

MIDI Guitar & MIDI Bass user forum

I can't get the Mac stand alone Midi Guitar 2 to work with Studio One Professional 5

I have just bought Midi Guitar 2 to use with both Logic and Studio One.
As a guitarist rather than a keyboard player, this is a game changer for me. It’s a great app.

Having tried the plugin version on both, I found that with Logic I get the fastest tracking and smallest latency when routing the stand alone app, set to the smallest latency value of 64, then hitting Logic’s low latency button when I need to record. Logic is set to 256.
In this way, I also avoid having to use Software Monitoring, since I normally monitor through my audio interfaces DSP mixer, and I have to keep it that way, since this is a commercial studio.
All I do is set the output of Midi Guitar 2 to “virtual midi output” and Logic will see it like a normal midi controller.
It works great, and the tracking and latency are very good.

Unfortunately I can’t replicate this setup in Studio One.
When I use the plugin, at my usual S1 setting of 256, I still get some latency that makes recording parts on time difficult.
How do I route the stand alone MG2 to Studio One? I’ve tried all that I could think of (created a new “keyboard” in S1 etc), but the daw will not see it.
I’d really appreciate some help with this.
Many thanks in advance :slight_smile:

Can anyone kindly help with this?

Im not so familiar with Studio One but I didn’t hear of others with this issue - maybe you have some latency compensation set in Studio One?

Did you use the MG VST or AU? The VST is recommended. Please see the Studio One section on jamorigin.com/daw

MG standalone or AU will create a virtual midi device and it should be available just like any other MIDI device in Studio One. In fact, its the same virtual midi device regardless of whether you use MG standalone or the MG AU plugin - and MG will send out MIDI at the same latency regardless of who is receive it.

On Mac, the VST is typically a bit different - in most DAWs VSTs can output MIDI directly so it doesn’t go through virtual midi.

Thank you for your reply.
I’m using the VST, but it shouldn’t matter since I want to use the stand alone app to input midi in Studio One.
I don’t have any latency compensation set up in Studio One.
As I said, with Logic all I have to do is set the stand alone application to “virtual midi output"
and Logic will see it as any other midi controller. With S1 I can’t get it to work.