Jam Origin

MIDI Guitar & MIDI Bass user forum

Inconsistent issue in Cakewalk: High samplerate will cause CPU overhead

Hi,

I am completely new to MIDI Guitar 2, and currently evaluating whether I should buy it.
I use Cakewalk by Bandlab with a RME Fireface UFX+ and Vienna orchestral samples and software, and guess what…? I want to use my guitar to record the 220 MIDI Vienna instruments tracks I have setup.

The good: First, in one fairly simple Cakewalk project (6 audio guitar tracks and 2 midi tracks for bass and drums), I was able to add a new audio track, plugin my guitar and hear the audio, then add MIDI Guitar 2 as an effect, and hear piano sounds, all good!

The bad: Then in the same session (and later after close/reopen Cakewalk), I switched to another project, much larger (220 MIDI tracks using Vienna orchestral instruments), I did the same thing, added a new audio track, plugged in my guitar, heard the audio, added MIDI Guitar 2, heard only clean guitar tone, no piano. I see the following error in the Host Information panel:

  • You are running at a high samplerate. This will cause a CPU overhead and no quality benefits as far as MIDI Guitar is concerned.

I have not touched the samplerate in between the two projects, it’s set at 44.1 KHz with 32 samples latency, normally working just fine. The computer hardware is pretty high end.

Any idea on what could be wrong?

Below is a screenshot showing audio going through on track 221, the MIDI Guitar warning sign, and the Cakewalk driver settings.

Thanks!

220 midi tracks at buffer=32
I think it is just overload, buffer=32 is very, very low. Just try switch to a bigger buffersize.

Ah yes. The warning is misleading. The warning comes when your buffer size is under 1 ms (ie. bufferSize/sampleRate < 1ms). Usualy that means you are running a high sampleRate (like 192Khz) as very few are able to run buffers of 32 samples @ 44.1 hz. I guess if you go up to 64 samples, the warning disappear?

@Paul and @JamO, thank you both.

I tried to change the buffer but that did not do anything and then I found out the lameness: the problem was the checked setting “Bypass FX Rack” on the context menu of the Midi Guitar effect insert… Not sure why that got set, I had created the track then inserted the effect, that was it.

After unchecking this, all is good, I hear Piano!
Though I did up the samples to 64 to avoid some clicks.

Now trying to figure out how to route MIDI from this track 221’s MIDI Guitar 2 to my solo cello on track 145… 145 is receiving signal just fine from my keyboard on MIDI Omni, but not yet from 221.

Reading Cakewalk docs…

Aaaaand I got it!
Just check the Enable MIDI Output menu, as it says in the MIDI Guitar 2 docs and it works of course.

Got some cello!

A bit more looking around and I may be on my way to buy MIDI Guitar 2 and never ever consider a MIDI pickup again.

This is cool, thanks!

1 Like