Jam Origin

>> MIDI Guitar & MIDI Bass user forum

Kontakt 5/6 - Not Recording Midi With Reaper and Win

Followed your video exactly for use with Reaper (latest) and loaded Kontakt instrument (organ). Tried Kontakt 5 and 6; same results. I can play and hear the instrument, but recording does not work. Reaper “thinks” it’s recording and saves and an empty Midi file on the track.

Midi Guitar is recording with other VI’s (e.g. Waves keys), just not Kontakt.

Thanks.

the recording options Reaper are complicated, and there are different way to use MG in Reaper.
Have you checked that your are recording the “midi output”?

Thanks for the quick response :slight_smile: Yes I have Reaper set to record “midi output” but…

Solved it. It is a setting in Kontakt.

In case anyone else has this problem, in Kontakt:

Go to Options/Engine and there is a setting for “Send MIDI to outside world”. I selected “incoming CC’s” and “incoming notes” and it work like a charm now.

Thanks again.

1 Like

ok, I understand!
It works like this:
if you use Kontakt, it will “eat” the midi, and since we’ve chosen to record the midi on the end of the chaing (“midi output”), Kontakt has to propagate its MIDI… Hence the “send midi to outside world” needs to be active.

There is another way of using MG in reaper: then you create a midi send in the MG channel’s I/O options. Create the instrument track, and add the midi receive there from the MG track. You need to fumble a bit with the monitoring options, but then that also will work.
MG then can be loaded in the normal FX section, which also can read recorded audio
data.

That’s a good description, Paul; Kontakt “eats” the Midi. Thank for the other options also.

1 Like