Jam Origin

MIDI Guitar & MIDI Bass user forum

Logic - No sound on recording midi guitar

I use latest logic pro x.
Set up audio channel and linked to midi guitar 2 as fx. Added 2nd track software instrument. As per web instructions. This all works fine and I get the sounds I have selected.

Then when I try and record this - the sound disappears and all I hear is the guitar. I have no other changes made

Help please greatly appreciated. Why can I hear the sound when I play over a track, or when there is no track playing. I keep input monitoring on in all cases BUT when try record the track I cannot hear the instrument chosen???

The “software instrument” track in Logic is a normal track in Logic and behaves like a normal track that plays software instruments via midi. There is nothing special about it, other than it receives midi from a virtual midi connection, rather than a midi keyboard.

Maybe you are trying to set up software instruments inside MG and record them?

There seem to be problems with Midi Guitar 2 and Logic. I can’t get it to make any sound in Logic even though I’ve followed the instructions very carefully. I’ve tried it on two different computers with two different versions of Logic, it doesn’t work on either of them.

Thank you for reporting! Obviously this is very critical for us to understand, if there is an issue.

I have no problems here on Big Sur and Catalina, and I would expect more reports if there is indeed a common problem. But perhaps you guys have something in common that makes it not sound.

If I understand correctly, you can add the MG AU as the video shows, but please help me understand:

  1. Go to Logic Preferences and Plugin Manager and verify that you have MG AU v2.2.1 installed and validated. Sometimes its necessary to Rescan and Restart the Mac after installing new plugins.

  2. When the MG AudioUnit just sits there on an audio track in Logic, it will behave like any other AudioFX - it will output sound. Please verify that this works: pick the test piano inside MG and you should hear piano. This is not about MIDI yet, just an audio track that throughput audio.

  3. Now, please go to Logic’s Preferences and let me know if there is a “MIDI Guitar #1 out” virtual MIDI channel. I suppose this is where it breaks for some reason.

  1. Please let me know which version of MacOS you use and which version of Logic.

EDIT:

  1. One explanation could be that you guys forgot to license MG and it stops and wait for you to click the interruption inside MIDI Guitar?

EDIT:

  1. After spending some time today with Logic, I realised that the most likely cause for MG producing no sound or MIDI is that Logic’s buffersize is too high for real time latency (higher than around 6 ms or 256 samples @ 44.1Khz). In MGs “Interface” tab it will show the buffersize and display a yellow warning triangle in case its too high. Logic is a bit unusual in that it will use lower buffer sizes only when actually recording.

To set buffersize in Logic, go to Logic => Preferences => Advanced and make sure Advanced settings are enabled. Then in Logic => Preferences => Audio => Devices, set your buffersize AND Process Buffer Ranges to Small. Also, in in General tab, set Low Latency Mode and turn off Latency compensation.

Hei. Same problem here. Just bought MG and connected it with a new Logic Pro 10.6.1. Everything should be ok and I followed all the instructions also given here now, concerning buffers etc. No sound. I can record through Standalone, so the programs do communicate. But plug-in cannot yet do the same. Can you find any more tips? Are these problems of setting (one needs to use the 1st audio track etc) or are there some new developments in the programs that should be taken into account? In regard to the video, everything goes well until the software-synth is chosen. Then nothing happens. I look forward for your tips.

  1. But I just need to add that I get not sound at all from MG in Logic, not even the test piano.

MG will bail out and be silent IFF the host give it large buffers (> 6ms). That is to avoid people experiencing bad latency and not knowing its from the DAW. Logic is known to use large buffers until you hit space / play the track. So that’s almost certainly what’s happening here. You can see if MG has bailed out by opening the “interface” section and it will show warning and tell you the buffersize it gets from Logic.

Further you should check your buffersize settings in the audio device settings as advised above. Different audio interfaces have different audio settings, so it might look a little different than in the video tutorial.

I finally got it working. Lowering the buffer size and process buffer at low settings was necessary, but that wasn’t enough, it still didn’t work. But today I was trying it again and I accidentally clicked the record enable button on the virtual instrument and suddenly it worked!

So it seems to need all three things in Logic, low buffer (I have 64), low process buffer, and record enables on the virtual instrument track.

Interestingly, you don’t need to do this with MainStage, it just works in MainStage, at least for me.

I am having similar problems with Logic X (10.5.1) on a MacBook Pro 10.14.6. Standalone works fine but in Logic the audio for the guitar is there on a track but there is no midi action happening with the Audio unit (loaded as a plugin). I had trouble downloading the trial version so I just bought the app a few hours ago.

My goal is to use this as a controller, in Logic, with my orchestral libraries (Spitfire, VSL, Native Instruments…) so far, that has not been possible.

I have lowered the buffer to the minimum - 32 and it’s set in low latency mode

Any help would be appreciated - thanks, Ed. Edward.edmusic@gmail.com

With some help from my friends on the Screen Composers Guild of Canada discuss list I managed to get the application working in Logic. This information may have been on your site and I missed it but, what made it work was to open the Midi Guitar 2 application, setup the tool as a midi monitor (to make sure the fault was not my Focusrite), set the instrument to no instrument, open logic, create a software instrument set to midi channel 1 (tried Kontakt and Spitfire) and it works. I had previously set Logic audio preferences buffer size to 128 - it tracks better at 64.

I think the mistake I made was opening Midi Guitar 2 as a standalone and a Logic instance either as a software instrument or as an audio file with MG2 as a plugin. Both of these overloaded the interface on the open standalone instance and stopped Logic from working - and crashed Logic a couple of times.

Will carry on working on my music and report back to you if anything changes. Happy to look at MG3 when you think you’re ready, all the best, Ed