Jam Origin

>> MIDI Guitar & MIDI Bass user forum

Logic Pro X: MG2 plugin doesn't show up. No Devices shown for input

Hi,
I’m a new user.

Logic Pro 10.4.4

VST and Component plugins installed properly.

When attempting to select MG2 in Logic’s audio track “Audio FX” window the Jam Origin folder doesn’t show up.

Was it not installed?

Thanks for your help

did you copy the midi gutiar2.component file to the right location?
it should be copied to /Library/Audio/Plug-Ins/Components/

If it is there allright, but not visible in Logic after a restart of Logic:
in Logic: open preferences / plugin-manager, locate MIDI guitar 2,
select it and choose “reset & rescan selection”

It’s in the correct place, but I haven’t rescanned. I’ll do that now. Thank you.

1 Like

FATAL ERROR: OpenAComponent: result: -1,0xFFFFFFFF
validation result: couldn’t be opened

most likely you copied the shortcut to the component file into the plugin folder, not the file itself!
from the install dmg, select midiguitar 2.component and use cmd-C to copy that file, select the plugin folder and hit cmd-v

The component file is 12.2 mb. It’s the actual file, not the shortcut. I tried a fresh download and install. I still get the same issue.

have you tried a system restart? there are cases where auval (the system tool that validate plugins, also for Logic) doesnt see new stuff…

I’ve restarted many times. Could the component file be corrupt? Have others had this issue?
Thank you

it is not a known error. So the file must be corrupt somehow: this has happened before.

Logic show the version of Midi Guitar 2 as 2.2.1
It says “Compatability: could not be opened”

can you send me the component file?

see PM here


Thank you for the new download. Unfortunately, I have the same issue.

logic Pro 10.4.6 is the most actual version, maybe take the update there.
Which macos version are you runing?

Logic 10.4.4 (I’ll update it to 10.4.6 now and report on the results)
Mac OS 10.12.6

ok, macos version 10.12.6 shouldn’t be a problem.

I removed the original MG2 files using “App Cleaner”. Then, I did a clean install. Same issue.

Now, I’m updating Logic to 10.4.6.

FIXED!!!
Updated OSX 10.14.6
Logic Pro 10.4.7

Thank you for your help.
Robb

1 Like

nice to hear!
Software is software, and strange things can happen between updates. See also the reports about macos Catalina (in short: you better postpone Catalina untill later)