Magix Samplitude Proprietary VSTs not showing

As a new user of MidiGuitar2 I am super enthusiastic to explore it, but only own one stand-alone VST, at least it is the only one recognized by Midiguitar2… it looks like my Magix DAW uses some kind of proprietary VST format not showing up in scans. The 10 year old tutorial on YouTube is not much help with newer versions so I have been unable to reroute and trigger miditracks using these other VSTs. Does anyone have a clear procedure perhaps using another Daw that might help me configure MidiGuitar2 to use my guitar to trigger another track’s midi ? And on a side note, is it possible to trigger any of my ‘real’ synthesizers? I am coming from still using an IVL Pitchrider 7000 which works beautifully for my style of playing. MidiGuitar2 excites me for how versatile it is after you record that initial guitar track plus being able to use any of my guitars, it is by far a better choice!

Use the “scan file” option in standalone version of MidiGtr. Scan dll’s separately. Once this done, your Vsti’s will appear in plugin version also and you can choose them in the instrument window of MidiGtr. This way you can trigger 3th party Vsti’s on the same track directly. And yes, there is a different way. Mean you can trigger “in theory” the Vsti on another track, once you ‘re routing Mgtr’s midi out to Vsti’s track midi in. Don’t forget tick in Mgtr’s plugin menu the send midi option and activate monitor button on both tracks. So, there is two ways to play with Vsti’s. But! I wrote in theory, because I’ve been struggling with the second approach for days. I’m using Samp ProX3 and Samp ProX8. In 3 everything’s going fine, but in 8 I can’ solve the problem. No sound on the Vsti’s track. After recording the Vsti’s track containes the midi data and I can play and hear it, so the routing is right. I asked about this issue here and on the Samp forum also. Didn’t get solution. Very frustrating. I don’t want to change my usual DAW to another and I love Samp. This is my experience.
About triggering real synths: I have not tried, but I think it may be possible. Just connnect your soundcard midi out with synth’s midi in and try the standalone or plugin version of the Mgtr. Don’t forget to mark the right midi channel.

1 Like

Nice to meet another Samplitude user. Thank you for your help - I did run the MidGuitar2 app as standalone and did a scan of my computer, it found the only VST I purchased outside of the various ones that come with updates to Samplitude. Those did not load or were not found by the scan, even going into the VST folder (they might be hiding somewhere else). You are correct my Hybrid VST then showed up in the plugin version. I was also able to trigger my external synthesizer from the app but still no luck with the plugin. It is a curious discontinuity feature. Since I have to run my Samplitude DAW to record, I tried running the app in the background to record my synth but then an error showed up with both the MG2 app and Samplitude accessing my Octa-Capture Midi interface. Took a while to get things back to normal. Really wish I could get my re-routed track working from with Samplitude, the problem you speak of with Pro8 sounds close except I do not get a recorded midi track. The way it is explained when I asked ChatGPT was kinda hopeful, but I will share it here as it might work on your system (did not on mine, thanks AI:

How do I configure MidiGuitar2 using Magix Samplitude 2020?

Configuring MidiGuitar2 with Magix Samplitude 2020 involves setting up both the input and output MIDI connections. Here’s a general guide:

  1. Open Magix Samplitude 2020: Launch the Samplitude software on your computer.
  2. Create a MIDI Track: In your Samplitude project, create a new MIDI track where you want to use MidiGuitar2.
  3. Insert MidiGuitar2 as a MIDI Input Device:
  • Go to the track settings or inspector for the MIDI track.
  • Look for the input section and select MidiGuitar2 as the MIDI input device for that track.
  1. Configure MidiGuitar2 as an Instrument:
  • Open MidiGuitar2.
  • Set your guitar interface as the input device.
  • Make sure the MIDI output is set to your MIDI interface connected to the external synthesizer.
  1. Arm the MIDI Track for Recording:
  • Arm the MIDI track for recording in Samplitude to enable it to receive MIDI input.
  1. Adjust Settings in Samplitude:
  • Check Samplitude’s preferences or settings to ensure that it recognizes your MIDI input and output devices.
  1. Configure Synthesizer in Samplitude:
  • If you’re using a virtual instrument in Samplitude as your synthesizer, make sure it’s configured to receive MIDI input from the track where MidiGuitar2 is assigned.
  1. Play and Record: Start playing your guitar, and Samplitude should record the MIDI data generated by MidiGuitar2 on the MIDI track.

Yep, I’m one of the rare Samp users. I use Samp since 2009 and I love it. I got used to it.
So, first of all. Where yuo can find Vst’s folders? Vst 2 are in the Program files (if you use Win), Steinberg and Vst Plugins folder. Vst 3 are in Program Files-Common files-Vst3 folder. I suggest not to scan folders. There is option in MGTR, that scan files. I scanned vst’s dll’s one by one with this option, wit success.
Samps own plugins are in Program files-Magix-Magix plugins folder.
Second: AI is wrong at the first moment. The MGTR track should be NOT Midi track. It works on audio-stereo track. On Midi track it won’t working. But when you add MGTR via plugin browser, the track will be automatically audio, not midi. Of course, the second track with some Vsti should and will be a midi track. But that is automatically also. And very important to tick in MGTR plugin menu the Send midi option. Then on the second Vsti track, you should assign midi in to 1.track MGTR out. As it turned out, my problem was a bug in the Samp 8 update. Hope, they will fix it in the future.
So, what you can do, if it’s not working? Arm the tracks as written above. Before scan needed plugins one by one in the MGTR standalone., once this done, the plugins will apppear in MGTR plugin version too. So, You have two tracks, MGTR and Vsti track, rooted properly. And yes, if you are recording something, on the second track you’ll get Midi signal. And you can play it. But no sound during recording. You have to use the same Vsti in the MGTR’s Select Instrument option. This way you can hear the Vsti’ sound, you can record and because you got a midi signal on the second track, you can play it. Don’t forget mute MGTR track during playing, because you will hear same signal duplicated. But once you record the midi signal to the Vsti’s folder properly, you don’t need the MGTR track to be activated. It’s just the trigger. That’s all.
Unfortunately pitchbend and vibrato option still not working properly, at least for me. But as I’m reading posts, this is MGTR’s bug. And they are working on it. It’s a nice app and it’s under development. You can edit expessions later by automation on the Vsti’s track and repair or delete unwanted or wrong notes.
That’s all what I know at this time.
Hope this helps!
Good luck!

Once again thanks for more clues… I keep seeing such references to using a second track, and the instruction to "very important to tick in MGTR plugin menu the Send midi option. " I do not see that option in the Plugin Menu anywhere.

Of course my first priority is really just be able to use that first Audio Track to trigger my External Synth. I have no trouble triggering the one VST I do own (Hybrid) using that track and I have no trouble triggering my Synth with the stand-alone Midtrack2… which I presume is set up right until I close it and try using it as a plugin to an Audio track in Samplitude, then only the VST instruments sounds in Hybrid and the few sounds MidiTrack has. The Outputs show Octa-Capture Midi in/out on ALL channels so hit or miss nothing triggers on my synth in FXplugin mode. If you have a screenshot, I would love to see a two track Audio/Midi routing routine setup, even for the internal VST of Magix.

Here are the pictures. First one shows the plugin menu, with send midi option. Second one shows the routing of midi in of the second track, assigned to MGTR. Doesn’t matter which VST we’re using. It works for me now, (Don’t forget activate monitor on both tracks). My problem was a bug in the Samp 8, after some update. It’s gone.