Jam Origin

MIDI Guitar & MIDI Bass user forum

MG is 2 semitones off - MG 2.7.4 and AUM (IOS 14.2)

After installing the latest update Midi notes becomes 2 semitone lower than the actual note In AUM, when external midi out is selected in MG. To overcome this I am using transpose tool of MG. Is there anyone who faced this problem too?

My rig: iPad mini 2019, Zoom UAC 2, Meloaudio Midicommander

Ok, the fact that its 2 semitones, is roughly the same interval as 44khz/48khz. So I think what you experience is that MG somehow think that you run at a samplerate of 44khz but AUM is actually running 48kz (or the other way around).

Please try to change the samplerate, and also try closing the apps and replugging your interface - maybe you also have some other audio apps running in the background that dictates the samplerate.

Its not something I can reproduce here, for now at least.

Edit: another idea - could it be related to pitch bend? Maybe the “pitch wheel” is somehow stuck at zero which would be 2 semitones on most synth… Please try to disable pitch bend in MG and reload your synth to see if that makes a difference. I tried to experiment a bit but couldn’t reproduce this either.

Ok, I see there is a problem with pitch bend!
This is not affecting the AUv3 plugin, but the good old virtual midi channels.

We’ll get this sorted out in an update today (+24 hours for Apple to publish it).

1 Like

Thanks for prompt reply.

I have updated MG to 2.7.5. But the problem is not solved. Sample tank in AUM dose not work with MG. Though Sampletank standalone is working fine raising up 2 semitones of MG.

The update you are waiting for is 2.7.6 :slight_smile: I guess it might be out tonight.

1 Like

Just a quick note, as far as I recall SampleTank iOS is locked at +/- 2 semitones for its pitchbend range. It might be a good idea to double check the pitchbend range setting in MG2 to ensure it matches.

This may not be your issue but just thought I should mention it.

1 Like

I’m having the same issues. (2 semi tones off) hopefully update helps. Fingers crossed.

Please let me know:

  1. is this happening when using the “external midi output” patch (ie. virtual midi) or when running as AU plugin inside a host?
  2. Does it happen when just playing the built in instruments?
  3. What kind of audio interface do you have?
  4. Do you have the latest update (version 2.7.6)?

Where in the GUI (iOs) can i find the version number?

iOS => Settings => General => iPhone Storage => MIDI Guitar

I also have this issue. MG 2.7.6 -> ThumbJam. iPadOS 14.2

Virtual MIDI shows correct note, but TJ gets something 2 semitones out. I’m currently patching it by transposing -2 in MG

There are a bunch of apps that do this…I think there’s a list of them on the Audiobus forum somewhere.

For example, Sytronik for iOS (IK Multimedia) had this problem when using the AUv3 in a host for over a year until IKMM fixed it.

IMHO, I think you’ll probably find it is an issue with the third-party apps rather than MG2 but I’ll leave that to the developers to make an official call on.

OK, now I’m the idiot.
I had previously set a +2 transpose in ThumbJam to patch round the problem.
2.7.6 fixed the problem,but I forgot that I had patched ThumbJam,
It’s all correct now, and I’m looking foolish.
Sorry to have wasted your time
James

2 Likes

Ok, I was almost convinced I messed it up :slight_smile:

With so many ways to host MG and new iOS updates we can miss even obvious problems.

1 Like

MG 2.7.6 update: The problem of pitch off (external midi) is gone now. With MG external midi out Sampletank works well with AUM and standalone too. But I notice Midi channel changes from 1 to 2 in Sampletank’s live mood. All of my old presets of Sampletank’s live mood did not recognise MG data until I changed all the instrument channels from 1 to 2. This is not a problem. But I have to change the channel of all sampletank live presets again and save them. Anyway, thank you for solving the actual problem. .