MG2 in Ableton Lite audio fine but no midi

I cannot get the midi output from MG 2 to work in ableton live lite. Audio works fine. I have followed recommended procedures with no luck. I am beginning to think that ableton has disabled this midi feature in the lite version. If I use the MG2 vst interface in ableton lite to play on the vst keyboard midi does show up in ableton lite but it will not show up when I play my guitar. Ideas? Thanks

Forget about MG2 for a moment – Can you route midi from one track to another, say, for example, using the qwerty keyboard as a trigger? I’m a full version LIve 11 user – no problems here but I guess it’s possible that Live Lite doesn’t allow MIDI to be transported between tracks.

After I posted, I downloaded the 90 day trial of live 11 and I couldn’t get it to work there either. Since that configuration works for you I’m beginning to think my problem is somewhere else. Within the MG 2 plug in it tells me on the midi monitor that midi is being sent to ableton and shows me the midi messages being sent as they are created. Thinking that the VST might be corrupted, I removed it and re downloaded it from MG 2. That didn’t fix things. I was able to do the routing you suggested and it worked from the keyboard in MG 2 and the midi messages came up ableton but when I played from my guitar, no midi messages. I verified that the guitar audio does come up in ableton as expected, it’s just the midi that is the problem.

Hmmm, I’m not sure. Could you take some screen shots of your live set/routing? That might give us some clues.

As a test, have you tried using standalone and sending MIDI from it to Live 11 also?

I am running Windows 10 pro on a Microsoft surface pro 7 tablet. Running sound thru presonus audiobox USB 96. Ableton is 11 free trial.

These are my MG 2 settings viewed on the MG2 plugin via Ableton

these are my Ableton settings

The MG2 VST is located in track 2. It appears to be the most recent version, the date last modified on the file itself is. 3/24/2017.

Thanks for helping. I am not sure how to run the test running mg 2 directly into ableton

First thing that stands out is that your Audio channel is not armed Also, it would be better to feed it a mono rather than stereo signal. On the MIDI channel, you can select the track that has MG2 on it from the drop-down list. Also there is no synth to receive MIDI loaded on your MIDI track. Refer to the 1st image with REPRO-1 loaded as an example.

I’m guessing you have the setting that will only let you have a single track active at a time. Look under Record/WARP/LAUNCH Settings. Deactive ‘Arm’ under ‘Exclusive’. See 2nd image.

Hope this helps.

I will try your suggestions in the morning. Is it significant at the MG 2 midi ports do not appear in the port listing In the midi preferences page? If it is significant, how do I get MG2 midi ports to appear order to enable track? Thanks

No, since you are using a VST in Windows it will not create visible ports in your MIDI settings. You don’t do anything except select the track generating MIDI as the input source…as I already said in my last post.

1 Like

Everything is working, thanks for your help! I was following this video How to Set Up Jam Origin Midi Guitar 2 in Ableton Live - YouTube recommended on the JamOrigin site MIDI Guitar & MIDI Bass Support – Jam Origin

At 1:03 the video shows that after inserting the VST on the audio track, the midi shows up in the volume meter on the midi track when the guitar is played. In my case this did not happen ie the midi meter showed no movement. Consequently,I thought something was broken. I stopped the setup and spent time figuring out what was broken and trying to fix it. As I later discovered, the midi was actually working properly it just was not visible at this stage. To make it visible required the next step, adding a instrument to the midi track. Then my playing became visible on the midi track’s volume meter and everything worked as expected.

Perhaps the video was on different software versions. I am using Windoes 10, MG2.21, and Ableton11.


Hi. I am going to latch onto this conversation. Perhaps you all can lend some assistance.

This is my first time on the forum so, if this is not the proper way to bring this issue up, please enlighten me.

I am running Ableton Live 11. I have downloaded the demo version of Midi Guitar and run through the “How To” video multiple times.

The GUITAR CHANNEL seems set up fine.
Audio From: Ext. In and 1 (the audio interface channel I am using).
Monitor: In
Audio To: Master
The channel is active and armed for recording.
I have the MIDIGuitar2 plugin connected to the channel and its meter responds to the guitar.

The MIDI INSTRUMENT CHANNEL also seems set up correctly:
MIDI From: All Ins, All Channels
Monitor: In
Audio To: Master
I have a midi instrument from the Ableton instrument rack connected to the channel.
The channel is active and armed for recording.

I have been through these steps multiple times with different midi instruments and feel like I am configuring the channels according to the instructions on the video… but who knows?

The midi instrument generates output fine when I use my E-MU keyboard, but does not recognize signals from the guitar channel using MIDI Guitar 2.

As suggested earlier in the conversation, I verified that the “Exclusive” setting in “Record Warp Launch” of preferences is disabled.

So… I must be missing something that ties the output of the MG2 channel to the input of the midi instrument.

Any help would be appreciated. I really want to purchase this product, but I need to make sure it works first.

I haven’t used it in a awhile but I think I remember that in order to get your midi to your synth, you have to assign the audio track in which your midi guitar2 VST is situated as your midi source. Having all ins doesn’t work because the midi is coming internally not from a physical input. So therefore if your mg2 is on say audio track 2 then on your midi track where your synth is instead of “all ins” set it from audio 2.
Hope this helps

Regards Max