Jam Origin

>> MIDI Guitar & MIDI Bass user forum

MG2 kills sound in Logic

I follow along with the video instructions, again, as I’ve done this before awhile back and it worked. But now when I add MG2 to a track with guitar previously recorded it kills the whole signal. Here nothing, see nothing. Meters drop to 0 and no signal to MG2. But when I turn off the MG plugin I here audio again.

What’s happening?

Screencast Here

Your screencast show that there is input into MG, but no Midi converted.
This is strange ofcourse.
Repeat the test, but please open the interface section of MG, to see the buffer settings. When the buffer setting, determined by the host Logic, is too long, MG will not work.

Sorry I forgot to include this screenshot before. I saw that MG’s buffer is way out of whack with Logic, Logic doesn’t even go to 2048. Screenshot attached.

Logic can go way over 2048, if it starts multiprocessing/mulitthreading: that is where the Process Buffer Range comes to play. MG does not accept these large buffersizes.
These following settings will convert pre-recorded material with buffer 512, which is acceptepd by MG. When recording tracks ( “live tracks” ), the 256 buffer will be used.
Processing threads: automatic
Process buffer size: small
multithreading: playback tracks

What I meant was Logic does not allow you to select anything over 1024, at least on my system.

OK, so playback is working with these settings, live, I’ve not tried it yet. But why is the buffer info different between the two?

To be able to optimise performance and spread the workload over multiple processors, Logic uses larger buffers. The “multithreading” selector selects when these larger buffers are used, and “process buffer size” determines how big those buffers are.
“Processing threads” seems to max to the amount of cores you have in your computer.

If you select: buffer=256, processing threads=2, process buffersize=small, multhreading=playback tracks, the effective playback buffering = 512.
If you change threads to 8 here, the playback buffering will be 1024.
Now change the process buffersize setting to large, and you’ll have a buffersettings way over 1024…

As long as “multhreading=playback tracks”, a live track (recording enabled) will use the principal buffersetting (256).