MG2: Show or not show all audio plugins doesn't work at all

When I have scanned all my plugins, they show up in thrice, one for VST, one for VST3 and one for AU. When selecting the instruments or effects, it’s unwieldy to choose, and they don’t line up alphabetically. At the left column in the plugin scan windows, there’s a choice of SHOW. Which means if you tick them out (untick them) they’re not supposed to show up when choosing instruments, so I can stay with all my AU units if needed. Or only VST3 if I’d like. Now, this doesn’t work. They show up nevertheless and when I go inside that plug in windows, all the SHOW fields are ticked again. I tried to SAVE but that doesn’t have anything to do with it.

Latest version for Mac OsX 10.15

Yes, in MG2 deleting plugins was never implemented, unfortunately. You can easily delete plugins this way:

  1. MG2 => Preferences => Open Data Folder
  2. In the file explorer, delete the .txt files you dont want to have showing up.

OK thank you, but then remove the option of SHOW tick boxes then, since they doesn’t work.

Yes, it will work in MG3.

Unfortunately MG3 is for OSx 11,* and up. Not my cup of tea. Why don’t you repair bugs and quirks in the old system before diving deep into new versions which may have a lot more features but bugs still remain from the old versions?

Im sorry, but there won’t me any more updates of MG2 now… I have to focus my time where I can help the most. Thats in developing the tracking technology further and keeping up with Apple, Steinberg and Microsoft to make it useful.

Apple and Steinberg are unfortunately pushing us developers and makes it as difficult as possible to keep backwards compatibility.

This is a really minor bug and nobody noticed it all those years, so it was left unnoticed. But as said, there is a workaround…