Jam Origin

>> MIDI Guitar & MIDI Bass user forum

MG2 with AUM on 2018 iPad Pro 12" - issues

I have my iPad/AUM live setup on iPad Pro 2018 12" into RME BabyFace Pro, iPadOS 13.2
I use 64 samples buffer and 44.1 kHz sample rate. I mainly use Sunrizer and DRC AUv3 synths in AUM, and a bare minimum of MIDI OUT in MG2 setup. I love MG2 tracking of my acoustic guitar and resulting layers of sound from Sunrizer and DRC, however:

  1. I have occasional spikes on AUM DSP Meter, going to around 200%, causing cracks and pops in sound. I know the buffer is small, but exact same config without MG2 running, runs at steady DSP 50% with no issues. I tried to increase buffer size to 256 (minimum I can live with in live performance) to no avail:(
  2. When I change AUM setups, MG2 overtakes audio driver (excuse my ignorance:) and when AUM loads new setup, it no longer recognizes multiple outputs of RME interface. I have to kill both AUM and MG2 and sometimes even restart iPad completely to make AUM recognize RME Outs 1+2 and 3+4 (I use them for main outs and headphones with a metronome click)

I wish you guys could develop a simple version of MG2 without bells and whistles, just the converter - it works so damn well, after all:) Please! Just Audio IN and MIDI OUT and make it visible in AUM either as AUv3 or at least as IAA. Thank you for understanding!

  1. buffersize 64 is way too optimistic in your setup imho.
    In AUM without MG loaded, there are no midi events generated: when MG generates midi events, the loaded synths start to lean on your CPU. and the buffersize then really makes a big difference.
    if you have an empty patch in MG, there is nothing running but the converter.

  2. I have no knowledge about this specific problem: there is stuff switching automatic on iOS, and that seems to go wrong at that point.
    When you bind MG as IAA plugin in an AUM patch, it most likely will circumvent this hickup, but it is unsure whether that would work in a broader sense.

Hi Paul, like I said, increasing the buffer size to 256 makes no perceived difference. I have MIDI keyboard patched to the same synths, and there is MIDI messaging going on, that’s what made me make the MG2 the suspect))
I will experiment more and get back. Second issue is of lesser importance really, and yes, there are some inexplicable things going under the hood of iOS audio implementation.

Thanks for getting back to me so soon. I really want to have it all working reliably!

ok, you should try binding MG with IAA, that way the CPU thread of MG will be synced with the AUM thread.
MG can works as an IAA fx, the midi will however stay on the same route.

Ok, I’ll try that, Thanks!

1 Like

Ok, so with AUM loaded with my working setup, and fully working with RME interface, I created new audio channel and added MG into IAA Fx slot - it doesn’t load. When I go to MG it shows “?” in Audio Device field and when I touch it MG crashes…

It looks like AUM and MG compete for audio interface, so to speak?

no, in IAA situation MG wil not connect to the audio interface: it will connect to AUM.
better create a transparent starting situation. close AUM & MG. start AUM only, you should be able to add MG as IAA fx then without formentioned crashing.

ok, will try that)) I’m on iPadOS13.2 just in case

ok, killed both AUM and MG, started AUM and created one audio channel. Trying to load GM into Fx slot, it’s not loading(

increased the buffer to 256 and tried to load MG - not loading

no idea really… it should work… what happens if you start MG manually adn then selct it in AUM as IAA fx?

I can start MG but it has this “?” mark in Audio Device field. When I touch it it says IOS Audio and when I try to select Input Channel it immediately crashes

ok, that happens when MG is allready bound via IAA, so there is a connection with AUM allready.
I have take some timer with it myself: I can not give further advice now.

sure, please take your time

I have tested AUM and found the following things:

  • AU is not as stable as IAA: instances of AU do crash every once in a while. This is most likely not the fault of AUM: other apps also suffer from this, including MG itself as an AU host. There is something fishy still with AU, regrettably.
    -Binding MG into AUM via IAA seems to work well: I have loaded several synths in it, and the cpu is nice. You need to switch on virtual midi in MG, and capture this midi port in the synth channel ofcourse.

I tried loading MG into AUM a few times with no success. I do remember before 13.2 it did the opposite - loaded into FX slot, but I had to select audio interface/channel from MG menu not from the AUM channel slot. Now It does not load in AUM FX slot, but binds audio (that “?” mark). I will experiment more. Thanks for your feedback!

  1. create an AUDIO channel, with hardware input
  2. int the first effect slot choose Inter App Audio / MIDI Guitar
  3. now visit MG: set external midi out set to “virtual midi”
  4. also in MG: set the bendrange to 2 (default )
  5. go back to AUM
  6. create a second AUDIO channel
  7. as a source, choose your synth, be it an IAA instrument or AU instrument.
  8. in the menu left to synth source, select “Midi Guitar out” as midi source

Note 1: midi guitar needs to be visited once per session, to load the proper patch/ set the proper params.

Note 2: Changing your hardware audio in, will break all current IAA connections: you have to reload the current patch to repair that.

I deleted and reinstalled MG on my iPad. All done as advised: one audio channel in AUM with MG in first FX slot. It loads now. Still the audio input can be chosen in MG - not bound by AUM, AUM DSP meter hovers around 73% with no audio (and midi conversion) and spikes up to 130% when I start feeding audio and conversion begins. Any ideas?

you should not alter the audio chooser in MG while MG is in IAA mode!
my CPU usage is way below your usage, more like 15% idle (I have a normal ipad 2018)
please also check which other apps you are running.