MG3 and Bitwig (macOS) - MIDI pitch bend, where are you?

Are any other beta testers using Bitwig 5.2? I’m an Ableton Live user through and through but have been making gradual inroads with Bitwig this year.

I simply cannot get MIDI PB messages passed from the MG3 VST3 to a MIDI/Instrument track in Bitwig. MIDI notes on/off work fine.

I reported it as a bug but I’m thinking it might simply be user error as I’m not that savvy with Bitwig. Any ideas?

VST3 doesn’t use MPE properly. More info later I believe. Use the VST2 for now!

And for anyone using Bitwig for the first time, doubleclick the Instrument channel for the instrument MPE enabling option!

Is this VST3 problem only in Bitwig or is it across DAWs?

If MG3’s VST3 plugin version had a problem across the board I’m pretty sure we would’ve heard about it by now. I think it’s just a Bitwig thing.

MG3 VST3 works perfectly fine in Live 12 — including PB transmission and MPE — and various other macOS software environments (I can’t speak to Windows).

I noticed that there is a VST2 version of MG3 now but I’m afraid the pitch bend issue persists with it in Bitwig.

I am getting a similar result, although not identical. Using the MG3 VST3 in BITWIG I didn’t get any Pitch bends at all. But I get pitch bend for Channel 1 only also in MPE mode with the VST2 which has fooled me into thinking it was indeed fixed.

Let’s begin with identifying where to use VST2 instead of VST3. For every DAW where you can’t manually check a “MPE enabled box” for the MG3 VST plugin, like you do in Ableton, you should use the VST2. There seems to be a problem with getting the “MPE enabled” status to come with the VST3 plugin format by default at this point. And it is needed for those DAWs that haven’t even considered using audio FX plugins to pass along MIDI/MPE.

So the VST3 works in Ableton because we can manually change it to be MPE enabled. Other Daws. If you uncheck that option for the MG3 VST4 plugin you get the same or similar behaviour as you get in BITWIG right now.

The VST2 works with Waveform and Camelot for instance. And it send bends on all channels like it it supposed to, so I can only conclude for now that there is some sort of issue with BITWIG not letting all bend info through. I need to look a bit more at this to say anything for certain.

This is what BITWIG themselves has had to say on the matter:

"The way MPE works in Bitwig Studio is that MPE from a midi controller gets translated to Bitwig’s per note expressions, and those are being recorded in clips and used to play the internal Bitwig instruments. When playing back recorded notes with note expressions to VSTs, it converts it back to Midi MPE before sending it to the VSTs.

But if you generate MPE Midi within a device chain and then send it directly to our internal devices, there is no translation to the note expressions and the devices are currently not completely optimised to receive pure MPE Midi date instead of note expressions. This is something we might improve on in the future."

1 Like

That all makes a lot of sense. Thanks for breaking it down :slight_smile:

I guess we can still use standalone MG3 to drive whatever MPE plugins/Bitwig devices we have loaded in Bitwig. It’s just not quiet as “clean.”

For all the noise around Bitwig vs Ableton, Live has a lot more flexibility in terms of basic routing abilities, IMO.

1 Like

I would agree! I have only tried BITWIG to see how to setup MG3, but it would seem it is still a bit behind in its thinking about the MPE FX like Entonol, Fluid Chords and also MIDI Guitar unfortunately.

somewhat related: i’ve read that steinberg isn’t allowing the issuance of ‘new’ vst2 licenses. is mg3 not affected by this?

for my workflow/setup vst2 is preferable. it also seems as if vst3 is still a work in progress.

MG3 only display one plugin option in Cubase, and I would assume it is the VST3. And although every DAW seem to have its peculiarities when it comes to setting up with MPE, Cubase is pretty straightforward. You just open the VST3 on an audio track, and for any MPE instrument on a software/MIDI track, the only two important settings are under the “Routing” header. You specify the (MIDI) input channel “Audio XX - MIDI Guitar 3 - MIDI OUT” and change the channel setting below to “Any” and you should be good.

I might prefer another DAW for a lot of reasons, but as far as setting up it is pretty straightforward. So no, I don’t think there is a problem for MG3 here. (It does not seem to be affected by the lack of default “MPE enabled” state in the MG3 VST3 plugin either.

OK, just to clarify the Bitwig thing:

After putting MPE-capability aside, as of my latest testing, instrument plugins loaded in Bitwig WILL receive pitch bend data from the VST2 (not VST3!) version of MG3 when it is in either of the MIDI 1.0 single- or multi-channel LEGACY modes. Obviously, there’s still an issue with MPE but it’s good to know you can at least get MG2 level functionality with the VST2 version of MG3 in this particular DAW.


  • If using a native Bitwig instrument, you must enable the P. Bend “–> Expr.” setting and set the +/- pitch bend range manually. The possible range is +/-24 semitones. Make sure to match the pitch bend range in MG3. Be careful as MG3 can go up/down to +/-48.

  • If using third-party synths, you must deactivate the P. Bend “–> Expr.” setting or pitch bend data from MG3 won’t reach the plugin. In this case, the pitch bend range is dependent on the plugin’s interna; pitch bend settings now. Make sure to match the pitch bend range in MG3.

Regarding using MG3 standalone:

First, you must set up a MIDI device in Bitwig’s settings to receive MIDI from the MG3 app. Notably, MG3’s MIDI port is virtual so Bitwig won’t give you visual MIDI data at the top right side of the GUI.

You cannot select a specific MIDI OUT port in MG3 so you are 100% reliant on the virtual port, for better or for worse.

MG3’s MPE mode works fine (as expected).

-If using a native Bitwig instrument, you must enable the P. Bend “–> Expr.” setting and set the +/- pitch bend range manually. The possible range is +/-24 semitones. Make sure to match the pitch bend range in MG3. Be careful as MG3 can go up/down to +/-48.

-If using a third-party synth, you must enable “Use MPE” setting and set the pitch bend range on the relevant channel strip. The possible range is +/-96 semitones. Make sure to match the pitch bend range in MG3. Be careful as MG3 can go up/down to +/-48, no further. Do not activate the P. Bend “–> Expr.” setting on the main! Make sure MPE is enabled in the plugin too. YMMV, but for example, Animoog Z or Pigments require MPE to be enabled at the plugin level.

I hope this helps anybody interested. It took me a minute to figure it all out.