Jam Origin

>> MIDI Guitar & MIDI Bass user forum

Midi channel not recognized in Studio One Pro

55%20PM

I followed the Studio One Video for setting up an Instrument track but I don’t get the “midi guitar 2/channel 1” I only have the option for Midi guitar 2/midi callback. So therefore it doesn’t work for me. any ideas?

I have the trial version loaded and the same problem. It’s very complicated, I’ve been trying to find a way for days. LoopBe1 does not seem suitable, because I would have to switch to the standalone version. I think midi guitar is very important to me, if it does not work, I take another DAW - although I like Presonus.

the trial version does not have a plugin VST included: your problems with loopBE are not related to the post here.

The quickstart vid is made with a previous Studio One version: the naming of the midi channel apparently has changed, but the function hasn’t.
Just choose the midi port with “midi guitar” in it.

In order for me to get it to work I had to create a midi hardware keyboard. I also had to make sure the small gear icon on the upper right hand corner of the midi guitar 2 was selected. I dont know if this is the proper way but it works.

I dont know either if this “hardware keyboard” is needed… Basically all we know is in the quickstart vid.
I suppose it is time to update the Studio One quickstart.

1 Like

I noticed on the interface button of midi guitar 2 plugin that it said no midi out port found. That’s why I created it as a external hardware device. The only thing is when I load Studio One it gives a warning flag that the midi device is not connected until the session with midi guitar 2 plugin is loaded.

1 Like

The Pro version of PreSonus Studio One supports third party plug-ins but here’s just a reminder that neither Prime nor Artist include

Third-party plug-in support (AU, VST2, and VST3 plug-ins and ReWire applications)

However Artist does offer an

(Add-on available)

for an additional cost.

PreSonus Studio One Version Comparison Webpage

ok, listening to your findings, it seems that S1 has regulated the midi output from VSTs. That is not a bad idea: there is only output midi from a VST when you choose to attach a midi port to it, if I catched your story right. It is sure safer in preventing infinte midi loops.
Currently I am preparing Cubase quickstart update, next will be the S1 quickstart.
Thanks sofar for relaying your info!

1 Like