Jam Origin

>> MIDI Guitar & MIDI Bass user forum

Midi Guitar can't detect my instrument

Hi everyone,

I use Tonewood amp with the iDevice plugged in my iPadPro. It was working well with Midi Guitar 2 and Sample Tank yesterday. I was happy with it and was even convinced to purchase the MIDI Guitar Rig and MIDI Output last night. I updated my iPad however to IOS 12.4.1. When I tried to plug in his morning, the Midi Guitar app can’t detect my instrument anymore.

I made sure my iPad is allowing MIDI guitar to access the onboard mic on the settings menu. No other active applications are running too.

I can’t seem to find a way to make it work.

Is anyone having the same problem and found a solution?

Please help

First check if the “headset mic” is selected for audio input. The TWA uses the same input port as headsets do.
If you by any chance have the old version of our ipad: the old version doesnt work with iOS12: check the appstore for updates.

Hi Paul, thanks for your reply. I believe I have the latest version

I checked the Audio Device settings.
Before plugging in the the iDevice adapter, the Output Channel is showing “Speaker1/Speaker2” while the Input Channel is showing “iPad Microphone”.

After plugging in the iDevice adapter and turning the Tonewood Amp on, the Output Channel automatically changes to “Headphones Left/Headphones Right” however the Input Channel remains as “iPad Microphone” instead of “Headset mic”

I don’t know what seems to be wrong. This problem happens when using my iPadPro, i tried it on my old iPhone 5s and I was surprised that the app detects the Tonewood Amp pretty well. The Input Channel changes to “Headset mic” as soon as I plug in the iDevice adapter. Kinda difficult to navigate through the interface though coz the screen is so small.

to me it sounds like your TWA plug isnt slipping into the jacket deep enough or something.
Try the ipadpro without the protection sleeve: often the sleeve is in the way.