No input from any USB interface in Mac os 10.15 in Mg 2.2.1

Anyone had this problem?

I have recently had to re-install Catalina MacOS X as it is the latest system that works with my hardware Macbook Pro. I re-installed many soundcards usb drivers, even RME UCX. Even had a Boss GT1000Core which is an effects pedal that doubles as a decent USB card, as well as a borrowed Steinberg, and a Focusrite Scarlett.

Reinstalled latest MG 2.2.1 mid for Mac OS 10.15 and up. Restarted Mac several tmes.

No input whatsoever whenever firing up MG2 in standalone mode. All other standalone programs did, and does, with all of the abovementioned USB soundcards. As well as plugins for daws and so on. No usb 3, still usb 2. No other thing connected at the same time. Checked everything, it took me hours, half a day. No input happening in MG2.

It used to work with El Capitan 10.11.

On top of this, I tried to use even built in input in the actual MacBookPro, to connect something that produced input signal. And changed it in MG2 interface choices. It didn’t track that one either.

Did you check the permissions?

oh yes…sure did. thrice…

Ok, had to ask! Missed that myself more than once! :roll_eyes:

1 Like

Yes that was a good one. I discovered that, after like 30 minutes today, earlier, and went “ahha…I forgot that one…” and went in there. It could very well have been that one… checked it now again that it was ticked just to be sure it hadn’t defaulted to something when restarting.

1 Like

So, everything looks alright? You see your interface of course, but no action in the MIDI Velocity box or any movement in either of the noise gate strip or Input gain/db?

Now, after 2 days of headaching, I found in the same panel that you shown, there was on another tab further down what happens when you log in, something that automatically “starts”. It was an old Native Instruments “driver” that gets started everytime I login, even on old El Capistan. I haven’t used ANY Native Instrument hardware or software in like 10-12 years, but I sure used to, before they became obsolete (In my setup).

However, removing all software and icons for NI programs everywhere seemed NOT to get rid if this one, but when I removed this one manually from the starting up procedure it went well. Like that should be something that got in the way for the rest of the USB drivers or devices … sigh … beats me…

Find this peculiar, since it has worked before. And it still worked with all other daws on the Mac. GaragerBand, Audacity etc. Now when removing that one from starting up each time I logged on, everything inside MG2 went on very well, including input from every device I threw at it. Yes, I had to restart the machine, but now it works and I won’t rock the boat anymore now… :slight_smile:

Thank you for your help. Much appreciated.

1 Like

I mean, not even the built in microphone worked when choosing that as an input, even if I set it to the one you pointed out “allow application MG2 rights to use microphone”. But now, I still scratch my head, but move on, and not dwell or ruminate too much about it.

1 Like

I am glad you got it sorted out, even if it is not solved fully. I use a lot of NI stuff daily myself, but mostly software though, and I have no NI icon in that box. I checked my old computer as well where I know I used Maschine (my only NI hardware), but nothing there either. And I have had no clashes between MG2 and NI products that I know of, so it would be interesting to know what actually caused your loss of “mic permission” here. But, I too have left a bunch of unknowns behind. I don’t feel I have the time to bother with non-actual issues. There is usually way better ways to spend your time. Hope it keeps working for you. :+1:

1 Like

No, it is like this with all computers, and software all along. Something is lurking “actively” in there beneath the hood. I have updgraded and re-installed many Mac OS, up to El Capitan (had to still use the FireWire portion of it) but just now had Catalina installed for the first time. I e 10.15 . However, when reading up on it on wikipedia, it states, among other things:

Driver Kit:
A replacement for IOKit device drivers, driver extensions are built using DriverKit. DriverKit is a new SDK with all-new frameworks based on IOKit, but updated and modernized. It is designed for building device drivers in userspace, outside of the kernel.

It can be some 32 bit app as wqell, tiny snip of driver, or whatever still lingering, that the OS didn’t care to warn about, which is quite usual and common with Mac OS X. And other operating systems for that matter. I am pretty sure all my former NI software/hardware was 32 bit…

And if the reception for Catalina was like this when it came out in the first place:

" However, some critics found the OS version distinctly less reliable than earlier versions."

It’s little wonder, but now it works again, and that’s what matters. :slight_smile:

1 Like

From Catalina onwards lurking 32-bit audio/midi drivers could really land you in some computing crap. I remember the 32-bit MIDI driver for the Roland VG-99 taking a few years off my life.