Jam Origin

MIDI Guitar & MIDI Bass user forum

No sound with Reaper

Hello, sorry for my English I am French!
I would like to buy Jam Origin GT 2 but I cannot register it on REAPER despite reading several tutorials. I find it good in my VSTs, I set the latency, I use ASIO, and the MIDI out, but I have no sound. I can also hear the sounds of Jam Origin GT 2 when I am on REAPER but there is no signal when the recording is armed.
However, I have no problem recording MIDI sounds with a midi keyboard.
I have been looking for several days without result, that’s why I allow myself to contact you, I am new to MIDI recording. Thank you very much if you can help me !!

If you don’t see any midi notes in the MG user interface, it’s very likely you run too high buffer size in Reaper (for real time recording). Check the “interface” section in MG - it will show yellow warning icons if this is the case. And check your buffer size in Reaper settings.

Hello and thank you for your answer. I had already decreased the buffer size in REAPER and JAM Origin GT2 reports a latency of 5.8ms. Maybe I set the signal input and output wrong?

There seems to be 2 MGs in your screenshot?? (standalone and plugin)
Also, “WaveOut” in Reaper - that’s not an ASIO driver I think.

There are 2 MGs on the screen because I thought I had to put the trial version at the same time as the VST Jam Origin MG.
I took a screenshot of ASIO. Do you think the settings are correct? Thank you !

I removed the MG which allowed me to hear the midi sounds integrated into MG. I thought it had to be put on to REAPER. I took a screenshot with the VST MG alone, I still have no sound. I have to configure something wrong …

In my VST I have 2 choices of GT Jam Origin. Which one should I choose please? Thank you !

Capture d’écran Fx 2 Jam Origin

In Reaper your asio config is OK, but check in asio4all that your usb audio In & OUT are enabled :

In Reaper, see this snapshot (in french, but the pictures speak for themselves):

In Track 1 :

  • insert MG2 in the FX window
  • in MG2 choose DIRECT in the GUITAR-AMP/FX field.
  • route Track 1 to Tracks 2 and 3

in Track 3: insert any MIDI synth in FX window

Arm recording in the 3 tracks and record.

Thanks, I’ll give it a try but I don’t have quite the same REAPER configuration, I’ll keep you posted.

I just set up MG2 in Reaper on both Windows 10 & 8.1 and struggled to get sound out in both.
I found the ASIO driver works great in Windows 10 but I couldn.t get it to output sound in 8.1 (in Reaper only, the stand alone MG2 needs the ASIO and works fine in both).
1’st in either windows set up up your audio config.
My system is using digital audio thru usb from the guitar, but the the output is analog.
2’nd you need an instrument or a guitar effect loaded in MG2 or it won’t generate any sound.

In Windows 8.1 Reaper I’m using WaveOut set to usb microphone mono (left) for input and line 1&2 analog for output.
In Reaper 8.1 set the audio device to WaveOut, the input and output to match your windows setup, and set your buffer size (smaller buffer = less latency, larger buffer = less chance of buffer overrun and that horrible noise). You may have to add a send to audio hardware in the route panel (the button between the volume and pan control on the track).

In Windows 10 and for the stand alone MG2 I use the ASIO driver set to HD Audio Stereo inputs 1&2 and HDA outputs 1&2
.In Reaper control + P brings up the preferences, select Audio-Device in the left column and choose your sound config and make sure Enable inputs is checked.
THIS IS IMPORTANT click the ASIO Configuration button ( the driver button in MG2 stand alone) ,when the panel comes up click the wrench icon in the lower right (a red X will cover it). Click the + signs in the WDM Device list to show all devices and select only your active devices. The icons next the device and the icon for the categories should be lit up.
Close the panel and click OK (sound won’t be active while Reaper Preferences is open).

In both 10 and 8.1 if you add a vst instrument on the same MG2 track it gets the MG2 midi, but if you want to drive a VST on a new track you need to add a receive from the track with MG2 in the route panel (the button between the volume and pan control on the new track) and make sure midi’s enabled.
As far4 a recording midi generated from a plugin like MG2 or a drum machine etc. I’ve done it before in Reaper but I can’t recall the setup, it’s not that obvious but it is possible.

UPDATE: To record MG2 midi to another track after you set it to receive midi from the MG2 track in the route panel you right click the tracks record button and you set it to input midi -virtual keyboards & reroute the midi channel if desired, then select RECORD OUTPUT MIDI. Seems backwards to me but that’s what works.
On the MG2 track you can either record midi or audio but not both at once to my knowledge, but you can route either or both to a separate track.
I hope this saves someone from the frustrations I experienced.

PS If anyone knows how to remove VSTs from MG2 please let me know.
I was trying to load a couple of VSTs from a single folder and it scanned my entire drive and loaded them all!

Hello, welcome here :slightly_smiling_face:

What do you mean by removing vsts from MG?
MG does like any daw or vst host; it loads only the vst that you want to use.
If you mean that you do not want MG to scan all your plugins, use the “scan one file” function.
But lf you remove the MG folders, you will not be able to load any of them.