Jam Origin

>> MIDI Guitar & MIDI Bass user forum

Nothing happening with the MG2 plug-in in Cubase

Greetings all. I just bought the MIDI Guitar package and installed the 64-bit and standalone versions. I have been able to successfully get the piano patches on the standalone version to play. The DAW situation is a whole nuther beast, unfortunately.

I’m using Windows 10 / Cubase Elements 10.0.3/Boss GT-001. I went through all the setup videos I could find (not many, I admit), and I think I crossed all my t’s and dotted all my i’s. I set the buffer size on the Boss to 256 samples/44.1k and turned off ASIO Guard. I went through the steps just as described in the video - created a mono audio track, put the G2M plugin into the insert, created an instrument track with HalionSonic and set the input on the instrument track to the G2M 64-bit setting, making sure to match the MIDI channel settings.

Not only do I not hear the MIDI patch, I detect no MIDI signal going into G2M at all. I assume the theory is that the guitar input goes into the audio track, through the insert (plug-in), then to the stereo out (since I don’t have a submix bus set up for that purpose) - and then, the output from the insert is then routed to the instrument track, since the input has been set to the G2M option. Of course, the instrument track is not going to record or play anything if the insert in the audio track (G2M) has seen no MIDI at all.

What could I be missing? Thanks so much in advance - sure hope someone has gone through this. It makes me wonder if the product has actually been tested on the latest versions of Cubase. Given that the trial version does not include the VST plugin, seems to me the developers would take a little more care to test the product out before charging people for it.

Anyway, I’ll wait for the collective wisdom here…:slight_smile:

Srini

Hy Srini,

I have been using MG2 for some time with Cubase so I think I can help you.

I own Cubase Artist 10.40 and my PC is a W7 Pro 64 bits.

First thing, when I want to use MG2 in Cubase, I create an audio track and I choose the input channel of my audio interface where my guitar is plugged in.

image

Then, I select MG2 as an insert effect on my audio track

At this point, you should check that MG2 receives your guitar playing. When I click on the interface button, here is what is shown


Next, you add an instrument track in Cubase
image

On that track, you select MG2 as the input, and your vsti is your output

Then, you activate the MG2 autio track and your vsti track and that’s it !
image

Hope that will help you !

sorry for the mistake, here is what is shown when I click on the Interface button :image

Hi Manu, thank you so much for taking the trouble to post the screenshots and the step-by-step directions.

I’ve done exactly what you laid out (just as the setup video indicates). I think the problem is in your third image (the interface button) - not with your instructions, but with my situation. I get the exact same screen as you, but no MIDI goes to the G2M. I think that’s where the issue is.

I’ll start from scratch and try it again, though.

Thanks again for your detailed response!

Srini

Hi Manu,

Started from scratch once again and went through each of the steps.

Here are my screen shots - since I can only upload one image per post, I’m doing three posts.

First, the audio track

Now the G2M insert, when opened, with the interface tab open.

Finally, the MIDI instrument track settings.

Still the same - no MIDI response from G2M at all. Sure makes me feel like I’ve flushed my hundred bucks down the toilet. I hope I’m wrong…:slight_smile:

Srini

After years of owning Yamaha equipment, upgrades in Cubase, and etc. I have yet to be able to get one complete song into the program. (I used to use MIDI cables and music software in the 90’s and was able to use things relatively productively – not anymore)

I am attaching what I did to get it working in Cubase (the newest one). Be warned, it can only be used on one track at a time, so, I guess copy what you have in the MIDI part and paste it into a non MG2 track cause you can’t have any more than 1 going.

So I attached photos.

Thanks a million for the pictures and annotations. But, doesn’t what you did look exactly like what I did too? I actually saw your post on this very subject on the Steinberg forum, and followed it carefully.

Well, I’ll try it again, and let you know what happens.

Well Srini, I see on you pictures that the midi channel on the MG2 midi interface picture is set to 8 whereas it is set to one on your instrument track in cubase. The channels have to match. Choose channel 1 for instance in the midi interface menu of MG2 instead of 8 on your screeshot.

Now, the first thing you must check is that, even before you create an instrument track MG2 receives your guitar playing (play hard and check if the little bars in the midi velocity window of MG2 get white).

If MG2 receives your guitar playing it should work if you follow the other steps with the creation of an instrument track and make sure midi channels match.

Oops, in fact I just checked and the channels don’t have to match for MG2 to work…

Are you absolutely certain that the input channel you choose when you create your audio track corresponds to the physical input of your audio interface where your guitar is plugged ?

I know you must have probably already checked that but sometimes I myself forget that my guitar is plugged into mono channel 2 of my sound card and I wonder why MG2 does not work after having chosen mono channel 1 when creating my audio track…

Hi Manu, excellent points! In HalionSonic - as you know, since you use it too, you can set different patches to different channels. So I set the patch I wanted to channel 8 inside HalionSonic, and then set the channel in MG2 to 8. By the way, I had initially set it to Omni, and that didn’t work either.

To your point about MG2 receiving the guitar playing, that is exactly where I believe the problem is. It doesn’t receive any MIDI, because those bars don’t move no matter how hard I play.

You make another good point about the physical channels. The GT-001 lets you set two Primary (with amp sim, FX etc) channels, and two Secondary (Dry) channels. I usually only use one of the Secondary channels, and run that track through a different amp sim so I can blend the two. You’ll see the word “Dry” below for the physical input (although I have tried each of the other two as well, with the same result):

So far I admit I’m stymied! Thank you so much for sticking with me here!

Srini

I tried one more test just for grins. I set the MIDI channel on HalionSonic to 8, and then to “Any”, although I had the patch I wanted loaded into channel 8. No luck in either case. I checked G2M to see if any MIDI was going in - no luck. And now, the standalone version doesn’t work either.

I’m ready to call BS on this product. If it takes this much struggling just to get it to work, with absolutely no help from the product vendor (as much as I appreciate you guys here jumping in, this is an amateurish way to run a business), it’s not worth keeping.

I’m ready to find whoever I need to talk to to get my money back and just buy something that works. I’ve got tons of Waves and other plug-ins, and they all run just fine in seconds. Sorry, this is an untested piece of junkware that nobody should have the gall to charge for.

Srini

we have tons of happy users, using it in all major DAW’s, including Cubase 10.
The money back guarantee is 14 days, so you’ll get your money back, no problem.

Thanks. I’ve just finished uninstalling.

Manu and usafirefly, thanks a million for your help! The search is on once more for something that works.

Srini

You’re welcome srini, I’m sorry MG2 did not work for you cause I think you would have appreciated it. Hope you will end up finding what you’re looking for😉