Jam Origin

MIDI Guitar & MIDI Bass user forum

PC messages do not change AUV3 instruments on iOS

Hi together,

really like this great app, but have a problem with PC messages and AUV3 instruments:

Setup: iPad 2019 (iOS 13.5), Steinberg UR22mk2, Camera Connection Kit, Fractal Audio AX8
Software: MG, Neo Soul Keys 2 as AUV3, IK Hammond B3-X as AUV3

I named patches as written in the docs (000 Patch 0, 001 Patch 1…) and I see that PC messages are correctly recognized by MG as the patch name within MG changes when a PC is received.
But different patches use different instruments (e.g 000 Patch 0 uses Neo Soul Keys, 001 Patch 1 uses B3-X). The AUV3 is not changed when a patch is changed via PC. If I change the patch with my fingertips, the correct instrument is always loaded as intended. So this setup is not working at all for live situations.
Any ideas?

If this is a bug or if you think there is a better way to do it for my setup, please tell me.

Because I want my setup to be reliable in live situations, I didn’t think of using AUM or something similar. Just thought using a minimum amount of involved apps would be the best: Just MG and two AUV3 plugins.

I have also another issue with B3-X but I will create a separate topic for that.

Thank you :blush:

This is fixed in the beta:
https://jamosapien.com/t/beta-testing-testflight/303

NOTE: The beta has no more IAA, since it is offcially deprecated now.

Thank you for your quick reply :slight_smile:
Will check this.

1 Like

Can definitely confirm that this works with the beta. Using my Helix to send PC changes to MG2 and using Poison-202 and Synthmaster Patches.

I installed the beta and it works perfectly :blush:

1 Like

I find that the Beta still has problems. Upon installing it, my MIDI PC messages now do in fact load the correct AU however they no longer load the correct preset in that AU.
So, to be clear, when calling presets that point to different AU’s they do load the AU now, but my multiple presets that all call different sounds in my Moog D app, all call the same patch in Moog.
The real issue is that behavior is different when tapping the screen to load a preset and sending MIDI PC to load a preset. If I tap the screen, my various Moog presets I created load the correct Moog AU and call correct patches. If I send MIDI to change the program, I end up with the same Moog patch loaded.
FYI, Moog was my example. This happens across synth apps. The tapping of the screen works, the MIDI PC partially works.

as far as I know, the latest beta does not send MIDI PC to loaded AU’s…
are you sure you have installed the latest beta?

I installed it last night. June 15. Should be current.
Before the beta, tapping a M2G preset loaded the AU and went to whatever patch I had loaded through the AU. MIDI PC changes would change the M2G preset but the AU wouldn’t change.

After the beta, tapping the screen still works and loads the correct AU and the correct patch. Sending MIDI PC now loads the correct AU, however the patch within the AU always calls up the same patch in my app. Not the correct one. So it’s partially fixed but still doesn’t 100% mimic a screen tap of a preset.

ok, that sounds like the PC is still fed to the AU plugin. which is strange. I can recall having checked this, and also those other users here in the thread didnt mention it. I’ll double check ofcourse.
What beta version is displayed in Testflight there?

Version 2.6.17 is showing in my Test flight.

Its working now! I restarted the iPad and it’s behaving as expected. I should’ve made a reboot the first thing I tried. Sorry to be a distraction. Thanks for the support.

1 Like

nice to hear! I wasn’t aware apps could still be running while installing an new version, good to know…

I can confirm that it works as expected here with 2.6.17 :slight_smile: