Jam Origin

MIDI Guitar & MIDI Bass user forum

Problem with patch change

I am using the iOS version and having a patch change problem. I am using Line 6 HX Effects as my midi controller. The HX Effects connects to an iRig Pro I/O, which then connects to the iPad. When I create a patch with a 3rd party AU plugin, the patch gets recalled correctly when I select it via the MG interface. However, when I program my HX to do a PC, it loads the patch I created however the instrument is not loading correctly. The plugin should be loading as the instrument but it’s not. Instead, the instrument that was previously loaded stays. Again, everything works when going thru MG interface but not when i send midi from my HX to the iRig. I’m so close to getting this to work the way I want but not quite there yet. Any idea what is going on?

1 Like

The problem “AU wont load on remote MIDI Program Change” is known to use.
We’ll bring an update to fix the problem.

Thanks. Any idea when that will be released?

no hard promise here, but we’ve located the problem and looking for the best fix. we hope to have it fixed soon, it wont take weeks.

1 Like

Any updates to this? Really interested in adding MG to my live rig but not having the patch change work correctly is a deal breaker for me.

It is fixed in the last beta 2.6.17
if you want to join the beta please install Testflight and then open this url:

Note: Apple forces us to drop IAA, and we’re looking how to compensate for that…

1 Like

Did a quick test today. Seems to be working now. Thank you!!!

1 Like

Update - unfortunately I can’t get this to work at all now. As in no output whatsoever. It worked about one week ago when I was testing for a few minutes but now nothing. I have done a lot of troubleshooting and can’t isolate the problem. I’m using an iRig Pro I/O as my audio interface. Everything works fine with this set up on my MacBook Pro but not with iOS on my iPad mini. I have tried everything. I suspect it’s the iRig USB midi to lightning adapter. Maybe the iPad needs the oem adapter? Other possibility could be a power supply issue.

Any thoughts as to what could be the problem? Dying to get this into my live rig.

that sounds like a problem with your irig indeed (if it doenst work with other apps it wil also not work with ours). Cabling is first to check. Allways have spare cables, so get 2 ones if your current one is broken.

Definitely looking forward to the update to fix this. Gonna be an awesome tool to use with the Helix! Wish I could get the beta to work on my iPad Air2, crashes every time I try to open…

crashing ipads is not typical: can you try a clean install?
(you will loose your custom MG patches then). It involves trashing the MG app, and then reinstalling it from testflight.

On another note, I got everything working again. At one point I used a headset with a built in mic to hear output and that seemed to cause the iRig to use the headset mic as the input and not the guitar. Anyway after resetting the iRig by removing /reinstalling the batteries all is working again.

1 Like

The “Midi Guitar 2” splash screen would load, and then disappear, without loading the app…what I meant by “crashing” - I could have been clearer on that, sorry. Deleting my original Midi Guitar 2 app, then re-installing it from testflight did the trick. Running the beta now. The two features I needed - remembering the “midi pedal” setting and remembering associated patch settings on any third party iOS synths loaded under “instruments” after exiting the app and re-opening work great! What a fantastic product you have, can’t wait for the non-beta updated release! Gonna make all sorts of things possible with my iPad / Line 6 JTV59 / Line 6 Helix setup! Thank you!

1 Like

Beta 2.6.17 works great so far standalone! However when I try to load it in AUM following the instructions I found on this forum it refuses to load. My non-beta version I had installed before installing this beta version worked fine with AUM. Is this a known issue, or something unusual I am experiencing?

IAA is deprecated by Apple, so the beta hasn’t got IAA anymore.
IAA will most like dissapear from all apps within months from now.
We’re looking whether we can manage to make an AUv3 MG plugin, but it is not easy.