Sample rate 256 is set but still no good. how is anyone else using this in a DAW?

seriously now, how the hell do i get this message to go away please and thank you.


Set your DAW to use 256 buffer size rather than 128.

I’m having the same problem. After inadvertantly setting the buffer size to 32 I am unable to access the Audio Settings in Midi Guitar 3. I click on Audio Settings in the upper right corner of the warning screen but the link does not work - just stuck in a loop with the warning screen. May be a programming bug.

1 Like

I just solved my own problem by deleting the MG3 settings file at “~/Library/Group Containers/X6D2Q4W5A8.midiguitargroup/MIDI Guitar 3.settings”

1 Like

Aha, so… the “more options” in audio setting lets you select low buffersizes which MG will then complain about and you can’t get back.

So, this is for standalone users:
Please do the following:

  1. Close MG3.
  2. Delete the MG3 settings file at “~/Library/Group Containers/X6D2Q4W5A8.midiguitargroup/MIDI Guitar 3.setting"

We need to address this in an update…

This is obviously not related to the first post here which is about a DAW.

Just here to add, latest Logic, latest Mac OS. Getting the “too high latency” warning. Logic is set to 256/44.1.

This is something different, and what MG reports here is actually correct. Logic will use very large buffers, regardless of what you set, until you enable the input monitoring on the audio track.

I have input monitoring turned on.

I’m not able to get past this screen no matter what latency settings, sample rate or input monitoring options I use.

Anything else I should try? Or is it not yet compatible with Logic?

Sorry, I realised we introduced some issues like this in the latest version. There will be an update tomorrow that address this.

Awesome, thanks! Can’t wait to try it.

I probably wouldn’t keep stopping the user from using the plugin if the ideal environmental conditions aren’t met in leu of a recommended settings approach, because, well, it’ll tick people off.
I notice now I actually have to have the guitar track armed to go before I can get inside and use MG3, please don’t do this. All the new stuff and sequencers and synths are great and maybe you should think about making a mini daw or sequencer because you’re obviously talented enough (if so do you need investors?) but try to remember, the majority of people are probably going to use it for the original goal, recording midi for filthy synths and maximum chug riffs on guitar instead of fumbling our way around a piano or pad surface. Its starting to get a little bit tricky, don’t go down that road.


Your post reads like MG3 was out and the developer wouldn’t care about issues. If you just want to bitch about things, wait until the official release to see what is left to complain about.
I don’t know what “the user” expects from MG3 nor what the “original goal” was. I just can speak for myself and personally I’m very pleased with the new features and the way things go.
Further I don’t see what is hindering someone to play “chug riffs” and fat “filthy synths”. This even works with the current buffer size limitation, at least in my DAW environment.


@apiary , I agree with Dutti67, this is a beta release to work the bugs out. The V2 is rock solid and a testament to the developer’s abilities. Context. Patience. Chill out.

Also, don’t assume what will tick people off, or what they intend to use it for. Your description really does not apply for me. It may actually only apply to you for all I, or you, or anyone knows.