Jam Origin

MIDI Guitar & MIDI Bass user forum

Set up on studio one prime

Hi, hopefully someone may be willing to help. I bought midi guitar 2 to use in the free version of studio one (only a hobby musician), I appreciate I can’t use a VST but the sales page said that it would work routed through loop midi. I have set this up and all seems fine but I don’t seem to be able to get it to register an input on a track from the stand alone app.

It is registering midi input in the bottom left of the studio one display (no output though as i would see by plugging in my midi keyboard) and I have set the loop midi as an external instrument. I am either missing the finer points of setting it up in studio one (have tried everything I can think of) or it won’t really work?

Apologies if this is really basic, any help would be greatly appreciated.

(input via komplete audio 2, latency set to 128 @44.1 KHz in MG2)

MG standalone works for you in all other aspects?
Did you remember to also set the LoopMidi as output in MG standalone?
Also, mind with this kind of setup, on windows, you need a multi client ASIO driver, or two audio interfaces.

Hi thanks for the feedback, yes it works in all other aspects (really like it!) (works in Ableton lite as a plug in but i want to use studio one to have more tracks available) I have set the loop midi as output in the MG standalone. I do have two audio interfaces available…I wasn’t aware that would be necessary! How would they be set up?
Thanks again for your time

D’oh!!! One dedicated to studio one and the other to midi guitar 2, apologies for being really slow! I shall try this in a bit! Thanks again.

Yes, cables works best when you connect both ends :smiley:

2 Likes

Your other option, when using MIDI Guitar/MIDI Bass (which requires ASIO), is to temporarily reconfigure Studio One to use Windows Audio. Since you’re just going to be recording MIDI, that shouldn’t be a problem.

[Covers eyes and crosses fingers. :see_no_evil: ]

Hi, thanks for that, I figured the same thing. Alas no success, the signal is there but I can’t select it as an input for my audio track (as you would if it were a VST)

Unless anyone can tell me it can be done (fingers crossed) I shall have to give up on this :frowning:

You say audio track - if you feed in midi, you should record it at a midi track / piano roll - not an audio track.

Quite so, it doesn’t show the midi guitar as available for any track, I may just invest in the pro product and save myself the time :smiley:

I’m a studio one user and you’ll need to drag and drop an instrument track in and choose midi gtr stand alone as input for instrument track, synth etc… see attached

#input

2 Likes

How is LoopMIDI working for you, latency-wise? I had some noticeable latency when I tried it, that I didn’t have with the free LoopBe1. That has worked well enough for me that I bought the inexpensive license for LoopBe30.

LoopBe1

I don’t have any noticeable latency. My interface is a focusrite 3rd gen 2i2. I maty try the loopbe30 and see how it compares.

Hi, the midi track on studio one prime didn’t allow me an option to select the loop midi as an input. It was a little frustrating. I have upgraded to studio one professional and of course everything is set and there are no problems at all from the outset.

Thank you for taking the time to address this with screen shots, it really is appreciated.

1 Like

Cool, S1 pro is my DAW of chose and I love it. I think you will like it. happy reecording

Hi, I am loving it tbh and really enjoying getting to grips with it :grin:

1 Like