[SOLVED - Free Trial Not Apple Silicon] VST not working in Studio One on Mac

The trial version of MG2 isn’t Apple Silicon Native - assuming this is the problem here.

Hi There,

I’m trying to test the VST plugins but StudioOne refuses to see the plugin sorry. Have tried…

  • Restarting the Mac several times

  • Ensuring ‘Scan at startup’ is enabled and restarting Studio One several times

  • Resetting the ‘Blocklist’ in Studio One and restarting

  • Ensuring the VST is located in /Library/Audio/Plug-ins/VST/MIDI Guitar 2.vst

Screenshot 2024-03-14 at 6.55.54 AM

  • Ensuring that /Library/Audio/Plug-ins/VST/ is a location in Studio One prefs…

Screenshot 2024-03-14 at 7.19.01 AM

  • Ensuring I downloaded the 10.15+ version…

Screenshot 2024-03-14 at 7.14.41 AM

  • Turned off MacOS FileVault (just incase)

After restarting the Mac, I did get an alert saying that something was added but when I click to see the list, I definitely don’t see MIDI Guitar or anything from Jam Origin - does that matter? I think this alert was because I updated SoundID.

What am I missing here?

Any help much appreciated. Cheers, Ben

  • Mac OS 13.6.3
  • Studio One 6.2.1

I don’t see ‘MIDI Guitar’ or anything from Jam Origin in the Effects list…

Since we are focused on MG3, I must admit I forgot what is the status with MG2 on Studio One. My best guess is that the newest version of Studio One require plugins to be native Apple Silicon. The workaround for this is to run Studio One under Rosetta.
I suggest to wait a bit for MG3 entering open beta.

1 Like

Ah OK, MG2 is not Apple Silicon native - that will be it.

Thanks for that, it’s been a few years so I completely forgot this is still an issue for some stuff.

Cheers, Ben