Studio One 6 - Resolved - MG2 VST now working on both Mac M1 and Windows 10

I did my first post on 7th October stating that I was having problems on the Mac M1 with the VST not showing up when I updated from S1v5.5 to S1v6.

On 15th October I updated the post with instructions to say that I had got it working by using the AU plug-in with some corrections to the Presonus Blog article, however still no VST at this stage.

To be safe I continued using S1v5.5 on the Mac M1 as the VST worked, I could still transfer files to my Windows 10 gigging laptop and added that I would investigate it further on Windows 10 as at that point I had not installed S1v6.

The VST did appear on the Windows 10 laptop when I upgraded to S1v6, just the Mac M1 to resolve.

After 3 weeks of checking all my plug-ins out and making up a table of what worked and what did not I was tearing my hair out.

In the last few days I have updated the Mac M1 from Mac OS Monterey to Mac OS Ventura and now the tickbox to run S1v6 in Rosetta that did not appear in Monterey is suddenly there, I ticked it and all is playing well the VST is now showing up.

There are some differences in the way you set it up on the Mac M1 though, but at last the MG2 VST works and you can trigger other instruments with it.


had a similar experience with m1 Mac and studio one 5. In order for mg2 to show up in studio one, I had to run it in Rosettamode and then rescan the plugins While in rosettamode, then it finally showed up and is working now. So if anyone has similar issues that’s worth a try.

Hi there Lenz,

Out of interest what OS version was/are you on. S1v5.5 definitely worked for me on Monterey, I have just checked info and ‘Open using Rosetta’ is checked.

My problems started when I upgraded to S1v6 and I do not remember the Rosetta option being there or old age is taking its toll.

As stated above after upgrading the OS to Ventura I re-checked everything and when I saw the option to ‘Open using Rosetta’ there I automatically checked it and it resolved the issue.