Jam Origin

MIDI Guitar & MIDI Bass user forum

Studio One - no midi from Midi Guitar 2

I’m using Studio One Professional 4.6.0.55xxxx and MG 2.2.1 under MacOS 10.15.3 (Catalina)

MG sees the guitar signal and clearly converts it to midi as, if I select a VST / AU instrument within the plugin, it’s all fine.

But: if I create a separate track with a VST / AU instrument and select ‘MIDI Guitar 2’ as its input, it receives no midi input and (understandably) creates no sound.

There must be something really simple wrong here, but I can’t see it.

Thanks in advance.
Mark

have you followed the steps on https://www.jamorigin.com/docs/daw/#toggle-id-13 ?

Paul - thanks for the response.

Yes, I have followed those steps rigorously and repeatedly to no avail. I’ve also updated anything that can be updated, restarted MacOS and so on, so I’m baffled. Clearly MG is working as a VST within MG works fine, but MG doesn’t seem to be transmitting MIDI to VSTs / AUs inserted in other tracks.

Regards
Mark

ok, to rule out monitoring error, please do the following:
enabel a small synth in MG plugin, can be just the test piano patch.
Now while you enable and prepare the instrument track in S1, when the MG turns mute, it is a monitoring problem: the MG track is just not working anymore because you focused on another track.
If that occurs, please check the settings for live monitoring.

Hmmmm. I don’t think so - I’m very familiar with Studio One and its monitoring. If I set the VST to ‘all inputs’ and use the qwerty keyboard within Studio One, I get output. It’s as though MG just isn’t producing midi output, or that Studio One is not passing it to the VST’s input.

Any other ideas?

Can you please double check that MG itself runs (via “test piano”) when you are focused on another S1 track? I’m blind here, I can only find my way with hard results.

Confirmed (specifically the ‘audio input follows selection’ and ‘instrument input follows selection’ are unchecked in advanced preferences)

ok, next point for double check
At 1:06 in this vid , in the “Add Track” window, specifically MIDI Guitar, channel 1 is chosen for input in Step 6

next step:
On macOS: make sure your are not using the AU (Audio Unit) plugin version!
The AU will not pass through midi at the normal output port.

Paul -

Thanks for that.

it was indeed the use of the AU version that was the issue. Thanks for your help.

As this thread seems to have exited the public forum, I hope you won’t take any offence if I say that most users (certainly including myself) are oblivious to any distinction between AU and VST; a tiny bit of information on your site, on the forum or within the product itself would have saved both of us (mostly me) quite a bit of time.

I’m a big fan of the product having used it for some time (you may have seen me extolling its advantages on your forum yesterday) and I think it should and could be in every writer / producer’s toolbox.

Regards
Mark

1 Like

ok, nice that it is fixed!
This mixup with AU & VST sofar only occured with Ableton LIve. I failed to mention that Studio One also loads AU’s.
I’ll add a note in the Studio One quickstart.

The AU behaviour originates with Apple not supporting normal midi routing: the Apple DAW’s (Logic, Garageband & Mainstage) only support virtual midi ports.
(At least they didn’t when we last checked…)
In Mainstage this is a real bummer: you’d want to have solid midi routing in a live host, but no…