"Unable to check for updates" issue on Mac - cannot launch App

I’ve changed systems and want to install Midi Guitar 2 and Midi Bass on a 2022 M2 macbook air. I’ve downloaded the dmg files, installed into Applications, but I cannot launch. I get the error “Please check your internet connection and try again.” My internet connection is fine.

Am I overlooking something?

I’ve updated to 14.5 OS and now I’m getting a message that the Midi guitar app is not for silicon based processors, but intel. I’m guessing that was the issue beforehand as well…

So I guess the question now is how do I run the apps on my mac? Is there going to be a silicon based version or do I need to instal rosetta?

I think you’ll need to install Rosetta. Are you aware that MG3 (for macOS) is in the public beta testing phase? Scroll down the linked page for downloads:

Thank you! I’ve installed Rosetta and managed to launch MG2 on the mac for the first time. However, I can’t find the plugin versions. Standalone seems to be ok, but I haven’t seen a window asking about VST. Are the files automatically put somewhere?

Excited about exploring MG3 too! Installation for it went smoothly. plugin VSTs are available.

Do you mean you can’t load any of your plugins? If so you need to run a scan first. Press the “plugins” button (top left corner) and then run the scan.

I’ve scanned… MG3 is listed, MG2 is not. I’ve uninstalled and reinstalled. Still no MG2 plugin.

I guess I’ll have to focus on MG3. But it’s weird the MG2 plugins are not showing up.

What DAW are you using?


I just noticed the sample rate and buffer size restrictions for MG3… I need to figure out the MG2 plugin, for now…

Thanks for all your help.

Sorry, I don’t know Reaper but you might find some help searching the forum. I know that other users run MG2 successfully in Reaper.

I’ve been running MG2 successfully in Reaper, on Windows 10…

Is there a possibility, going through Rosetta has caused an issue? I haven’t been a Mac user for long…

I’ve checked the VST folders - nothing for MG2

I’m still not 100% sure what exactly the problem is. You can not find the MG2 plugin in Reaper?

That is correct. The MG2 VST is not in the plugins folder at all. Standalone MG2 runs properly.

Make sure both paths mentioned in the Reaper manual are listed to be scanned. Check if you find any MG2 file in those folders.

Maybe this helps:

Yes. That’s it. It was right there, I should have caught it. Thank you very much for your time and effort helping out.