Jam Origin

>> MIDI Guitar & MIDI Bass user forum

Use a controller for Patch Change [DISCUSSION]


#21

Definitely not solved. Patches are useless in MG if the change in midi channel isn’t sent to Logic. I setup multiple synth tracks all set to a different midi channel but regardless of which patch I switch to in MG they all continue to receive midi and play.


#22

well, I can remove that “[SOLVED]” anytime…
but in MG you select the midimachine “channel select” to adress diffferent midi channels.
Here is a simple working solution for 16 instruments:
-run Mg standalone with “channel select” loaded in the patches
-enable virtual midi out
-run logic and have 16 instruments assigned to midi channels like in attached pic.

NOTE: There is a possiblity to use “sidechaining” to get midi from your footcontroller into a loaded AU plugin (MG in this case) in Logic: this however performed badly the last time I checked. I will check this anew, since it is 2 years since I last checked this.

Per default, midi footcontroller data is only available in midi instrument tracks.
Info for getting footcontroller data to an audio FX within a DAW track is found on this page: https://www.overloud.com/node/166


#23

it was setup exactly as you said, and now showed, and all tracks sound at all times no matter the patch selected in MG. Doesn’t matter if I change the MG patch manually or with the Xchange pedal, same result.I even tried under the interface tab setting the channel to any particular one channel of the sixteen instead of Any/Omni and still all tracks play sound in Logic despite being set to different channels. Somehow the channel select midi machine either isn’t choosing the one channel I have it set to or Logic is ignoring the midi machine message. It seems like the latter since choosing one channel in the interface setting of MG also didn’t make a difference. Logic chooses to send any midi to all midi channels regardless of which channel I set MG to send on. Have you tried that work around yourself and had success?


#24

Logic is a bit weird with its midi
-go to menu: project settings / recording
-enable “auto demix by channel”


#25

Okay, now that works! I would not have thought to look under recording preferences for a midi setting but I can sort understand that being there. The only left over weirdness has to do with number 1 on the pedal. As I mentioned before the program number on the pedal is always one digit higher than the patch number in MG. I had set the midi channel in each patch in MG to one digit higher than the patch number figuring it would be less confusing since most of the time I wouldn’t be able to see the MG page behind the Logic page, I could look at the pedal and know which track I’m turning on. Except that when I go to program one on the pedal in order to turn on midi channel 2 which ever track in Logic is highlighted changes instruments to a “User Channel Strip Setting” I have which for some reason I had saved with the name “000-synthname”.

Easy enough to avoid using number 1 on the pedal but I mention this because it might be a clue to another work around. Set a series of channel strip settings with numerical prefixes and different synths ? Maybe be able to step through the series? I don’t know. Maybe I’ll explore that. I’ll let you know. Right now I just want to get to work programming all my performance templates to fit this protocol.
Yes! Solved! Thank you.


#26

if you omit using 000 as patchname prefix, and start with 001 as first patchname, the numbers on controller and in MG will be sync.
Also dont use the same prefix number twice, it is just an alphabetical which is now being used by MG: PC #3 loads the third patch from the patchlist.


#27

Yeah, I’ll delete the channel strip setting. I guess Logic accesses those in any open project. But some time I want to explore that possible way of changing instruments.