Jam Origin

>> MIDI Guitar & MIDI Bass user forum

Very strange missing notes


#1

Took me a while to realize it isn’t a tracking problem. When I came to record a part in a key where the notes in question where prominent it did become obvious. The D above middle C and the B above that will not send Midi. Just those two specific notes. D and B in every other register is fine. I cannot for the life of me figure out what could possibly be causing this. Anybody?


#2

Never heard of this, but I urge you to check one or two things:

  1. Does it show in the MIDI window that a “staple” (vu meter of some sort) jumps up to the celiing?

If not, it doesn’t goes into the MIDI enginge at all, and you have to check gain, and maybe noise gate settings.

  1. Does it miss that even when you play those notes ON OTHER STRINGS too?

I mean, you get missed notes on the 3rd fret B string (which is D above middle C) and the 7th fret on the first string (B above middle C) but not on other strings? I e the exact same pitch but on - say - thick strings?

  1. For clarification, since this is both a MIDI Gutiar & MIDI Bass forum, with posts intertwined between those, it is MIDI Guitar 2.0 you’re using isn’t it? Not the bass one…

#3

the DAW i use, Digital Performer, occasionally decides to capture one note (f# below middle c) as a MIDI command to change sequences. this seems like a broken key on my keyboard (because the note won’t play) or some other problem (why did the sequence suddenly change?), until i remember to check the key bindings and delete that one! anyway, check to make sure your DAW or some other software isn’t capturing that note…


#4

Well I just fired everything up again. Same arrangement in Logic Pro. And it’s fine now. It was missing those exact notes no matter what string I played the note on. The input meter on the midi track would just go dead, not register anything, when I played either of those two notes. I looked through Logic’s Midi settings in both the general preferences and project specific settings and I don’t see where there could even be a setting using specific notes to control anything. So beats the hell out of me. I wish I knew how that happened because I’m guessing if it happened once it could happen again.


#5

Yes, strange indeed. It could and would happen again. I find this strange. I agree with Tonycore that some midi filtering can be set inadvertenly somewhere. But if you fire up MG2 in standalone mode and it still performs badly there, then it’s a strange problem indeed. Standalone mode, makes the rest of your DAW MIDI settings devoid of any misunderstandings MIDI filter wise.


#6

In fact I usually use MGII in both stand alone and plugin modes. I’m using a foot controller to change tracks within Logic that are set to listen to one midi channel. Then I have patches setup within MGII that transmit on one channel only. That way I can step through different synths by stepping through the patches. But sometimes I like to have one synth that is set to more of an ambient sound that will bubble up at different moments. So for that I use MGII in stand alone so no matter what channel the plugin is transmitting the stand alone will hear it and keep playing.

I only mention all of this because I agree with tonycore, and you , given the way he described his experience, it seems like it must be something like that. I should mention one other aspect of my set up that may be different from how others are using it. I split my guitar signal at my volume pedal, taking the tuner output to the interface so that I’m sending a totally clean signal instead of out of the back of my guitar amp, which would have distortion and reverb and other effects possibly. Just found that this gives me much better tracking. So I take that signal into a separate track, compress it a little before it goes into the MGII plugin. So far this methodology has worked really well, except for this hiccup. Still trying to find a possibly more elegant solution to achieving these ends with a better foot controller.


#7

No, please don’t. Even if you think it helps a bit. No matter how little or how good the compressor is. I thought this too. What I’ve found, and it has dawned on me ever so slowly, is that the actual pickups, if hot, can induce compression to the signal which wreaks havoc on the MG2 tracking/triggering. Here’s what I propose:

  1. People haven’t thought of that too low action, to much fret buzz that is not picked up by the pickups, can wreak havoc on MG2. Having a little higher string action like that of an acoustic guitar actually helps because:
  2. If you have too low action, when you’re damping/muting the strings you’re actually fretting them instead, which may cause stray upper harmonic notes. It’s an intimate and delicate fine line between deliberately fretting, or picking a harmonic node, or dampening the string from vibration.
  3. Height of the pickups to the strings. Here’s were esoteric things like magnetic string pull, and too hot pickups that causes compression comes at play. If set too close the pickups will induce a drag or pull on the osciallting string making the note unclear, it sounds like that actual note, is out of tune, or a slight chorusing wobbling sound, caused by uneven oscillation.

You can check this with any tuner. Connect it and you’ll see that the meter/indicator will not ever freeze but wobble around quite badly and you’re not even able to tune up at all. Lower the pickups and see what happens. If the notes wobbles in the tuner, the MG2 will wobble to and zig-zag between notes, pretty bad and double-re-trigger and all sorts of things.

  1. Of course, when they’re too low, headroom is lost, and the noise will get in the way for MG2 to track completely. You have to compensate with the gain knob (on MG2) and then you may amplify other stray noises as well. Fingering scratches and so on.

  2. However, added compression from an external box, will amplify all this background noises too, and while it will “even out” the dynamics, it’s just detrimental to the MG2 and it will track harmonics instead of fundamentals of the note. Perhaps. No matter how slight compression there is, and no extreme settings.


#8

I take your point. Very true about pickups. Alan Holdsworth was famously down on hot pickups for that very reason. I will look at that part of my set up. I do find that the gain and the noise gate controls are most useful. I try not to use the dynamic curve control much as that really destroys the interaction with really good synths. My problem in part stems from my playing style combining flat picking with finger picking. I use a Keeley Four Knob compressor before my guitar amp and that really helps even out my attack. What about a limiter instead of compression, again, to even out the attack of at least the worst peaks? Although the signal would need to already be pretty hot for that to have any effect I guess. Do you find that turning down the volume knob on the guitar induces less noise into the system? I’m going to look into all this.

BTW. Turned on that same project yesterday evening and the same weirdness was back. Same two notes AWOL. But closed everything down and rebooted and it went away again.


#9

It seems you have some intermittent thing, issue going on, like “now you see/hear it, but now you don’t”. It can be anything, it’s strange for sure.

The Keely is one of the most posh compressors out there, that money can buy in pedal form. Those are held in very high regard by most people. You can’t go wrong with those. But as a four knob compressor you should be able to set that working as a limiter too, you don’t need a dedicated limiter.

Regarding pickups, most passive ones (single coils and humbuckers alike) do have a resonant peak frequency that is different from each model/make/brand. Active pickups like EMG has a more flat curve as well as built in limiting so to speak. A very mild and subtle limiting. But that’s why some people “hates” EMG and active pickups. I find them very useful and gets better tracking in MG2 due to (or thanks to) their high and clean output. The headroom to noise levels are pretty high, and no 50-60 Hz hum ever. Also, thanks to their “flatter” repsonse curve they may - as the detractors say - have a slight anonymosity to their sound. Some “too neutral” in character. I find the much useful especially when run through large pedalboards, and lots of effects running at the same time, which can mask and cover up other “sought after” vintage sounding passive pickups of the past. However, this flat curve (or really: flatter) causes MG2 to trigger SLIGHTLY more properly all across and along the strings, and MG2 are less prone to double trigger notes.

However, all this has no relevance to what you’re experiencing that all of a sudden it dodges two notes, the same two notes all of the time. You should check elsewhere if you have some default MIDI template set up that you use all of the time, or the settings from the past session gets overwritten by something else. But anyway, I find this very very peculiar. I mean, if it should have “problems” it should be many more notes involved, and behave like that all of the time.


#10

You should tell us exactly what sound card interface you’re using, guitar, even PC or MAC, and of course you’ve already told us about the DAW you’re using the Logic.And which sample rates and buffer settings you’re using.

If you own or have two guitars, try them each in the same setup. Just unhook the guitar cable from one guitar and hook to another. I agree, this is very strange, but I can’t help still thinking about some MIDI filtering that has been inadvertently set. Some screen shots would be nice too…


#11

I have a couple of each. A Motu 828x and a Zoom TAC-2r. And a Windows 10x64 desktop and a 2013 MacBook Pro , both running most recent updates. Both interfaces connected via thunderbolt ( PC is a custom build). I have a few guitars and a bass. Maybe I’ll try them all. This has all been happening on the MacBook though so It’ll be interesting to see if it happens on the PC. Of course that will be with Ableton not Logic. For that matter I can try Ableton on the Mac as well. I have been settling for 44.1 kHz and 256 buffer. Couldn’t find the time today to do any thing.


#12

Ok then we know. Perhaps someone else with exactly the same gear/setup can give a clue?


#13

Update. I had another incident. I had already been needing to go into the settings of the midi instruments in Logic I was using and select the “extended range” setting for each, something I had learned about regarding another problem I was having. I did have the thought, " I wonder if this will have an effect on the missing notes?". Lo and behold it cleared it up immediately. But now I wonder if I just traded one problem for another because I’m having a hard time with CPU loads. I had been loading some Apple Loop horn parts. So about four tracks of that and one track of drums and two soft synths via MGII and digital crackling all over the place making a clean recording impossible. I wish Apple would hurry up and redesign the MacBook Pro so I could upgrade. I mean really redesign it. Oh well.


#14

Ok, out of the ashes into the fire. Perhaps some of the synths or loops are of the hungy kind? I have had the same problem with a MacBook Pro from 2013. I mean CPU hogs, crackling. I don’t know if those horn loops are loaded into the track “in full” and you just chop them off wth mutes all of the time. I don’t know how many effects you have on top of the drums, Apple Loop Horns, the built in effects of the two soft synths and so on. I know reverbs IR can chew a lot, if they’re not of the convolution kind.

You should test if Logic has “freeze track” capability. It’s a tedious work, but whenever you have in your mind that you have finsihed the track, freeze it. Then its’ only volune change, and you can do nothing to it. You can “open it up again”. What I used to do if I multitracked and all 12 tracks couldn’t play at the same time, would mute those tracks I didn’t need if they were “open”. Freezing a lot of tracks renders the track a wav file playback with alll effects and eq rendered into the wav file. As fast as a track is frozen it just “plays it up” like you left it with all effects for it built in. And free’s up the CPU considerably. The effects don’t need to calculate in real time anymore. If you think you made a gaffe with that particular track you’ve frozen you have to “open” it again, so you can adjust the effects. Mind you that the track isn’t “then you have to put reverb on reverb” i e that the actual wavefile contains all the effects in the actual wave file and can’t get rid of them. You work on the same track, not a new one. A bit hard to grasp but anyway.


#15

Hah, you obviously work in Ableton. I love that track freeze capability. I just finished recording a couple of takes. I shut off all the horn tracks and the rhythm guitar. I was still getting those crackles. But the more I listened the less consistent they were. Always in different places even on recorded parts. The recording play back always had the noise. Did a quick mix and bounce with all tracks and NO NOISE! Crazy. I’m out of time right now but there’s more to look into. It sounds exactly like CPU overload. Exactly. But only on playback?


#16

So a quick and dirty mix of the track I’ve been working on. Listening to the play back in Logic gave all kinds of crackle pop. But I noticed not always in the same place on prerecorded play back. Meaning not in the actual recording. The bounce into mp3 is pretty clean. Sumpin’ else altogether. God I love beating my head against the wall. Don’t you?https://soundcloud.com/tom-rollison/mud-on-the-wall


#17

if you do a mixdown in a DAW, the mixing is done non-realtime, this means that there will never be overload crackles in the mixdown.
If you have crackles in your project, there are 2 ways to get rid of it, whereoff one is the best:
1)not recommended: set the buffersize in Logic audio prefs higher. This will lower the CPU cost of your playback, but also make your MG latency higher.
2) recommended:

  • Use only 1 MG. audiotrack at a time, mute MG tracks after recording the midi on another track
  • freeze any non-muted track you aren’t working on. this also means the synth tracks!
    ofcourse you dont need to freeze busses.
    Only this way you can create bigger projects with realtime monitoring of everything.