VST Plugin missing Studio One 5

Hey There,

I installed Midi guitar on my m1 Mac as recommended. The VSt Version is correctly installed in the vst folder, but when I open it, in Studio One 5 it only shows me a AU Version. Rescanning the folder didn’t help so far.
The AU version doesn’t output midi so its unusable for my purpose. So Does anyone have had a similar problem and Knows how to fix it.
And if its not fixable for whatever reason, is there a Workaround to make the AU Version output midi inside of Studio one?

Thank you.

I really would appreciate some help here, since nothing worked so far.

I reinstalled midi guitar, this time I only installed the VST version, to make sure im to using the AU Version. The VST Version is at the right place, but studio one still recognises it as AU plugin, wich makes no sense to me. The Plugin works fine on itself, but it has no midi output, wich is the main thing I use it for.

Does anyone have experience with this issue and could help me? I would really appreciate it!

If Studio One recognise it as an AU, it must be the AU…
Please check your plugin folders if there is an “MIDI Guitar 2.component” somewhere.

My best guess is that you have an older MG VST somewhere in your plugin folders and a.new MacOS version.
Make sure you get the right version from Download – Jam Origin and make sure you overwrite the any “MIDI Guitar 2.vst” and “MIDI Guitar.component” files.

1 Like

Thanks for the reply.

I deleted the AU but it still showed up. Only when I deleted it from applications the au didn’t show up anymore wich is weird. I deinstalled everything and deleted all the files, even from the download folder and emptied the bin. then i restarted and reinstalled just the VST to Library/Audio/Plugins/VST it doesn’t shows up. I did the same (as a last effort 5 minutes ago, so the problem appeared well before that) process with the older version for Mac or the midi bass which I installed as well just to test it.
I Also tried to put the vet into another folder and ad that location to the Studio one, also no success. I also manually reseted studio one, which I read on headspace might help, also no success. Im pretty much out of ideas to troubleshoot here anything input is welcome. Do you have any ideas what I could still try or do I have to give up on midi guitar? :confused:

also I recognised that studio one scans the plugin when I launch studio one. It shows that it scanned one more plugin then when I remove it from the folder. Maybe that helps to troubleshoot?

Did you look for the plugins in both ~/Library/Audio/Plugins/VST and /Library/Audio/Plugins/VST?
Which MacOS version do you have?

1 Like

Thank you for the quick reply :slight_smile:

I only have that Path once, I don’t know what this Symbol: ~ means? Should there be two folders? I checked again its in the VST folder, with the path you gave. That folder is recognised in studio one and all the other vet located there work and show up in studio one.

Im running on 12.4 Monterrey.

Running studio one in rosettamode didn’t bring any change either (Studio one forum suggested that)

The paths are:

Please open Finder, and Go => Go To Folder => paste in those two paths and see what’s in there.
Also check the VST3 folders in the same locations.

1 Like

Hey, I only have one path, but I got to work it now after countless hours

for whatever reason the VST2 only shows up when I run Studio one in Rosettamode. But I had to rescan the plugins in rosettamode in Order for MG2 VST2 to be detected. It wouldn’t show up on its own in rosettamode. Also the cpu hit between rosetta and nativ is quite annoying.
I can run Studio one in native mode and use non M1 ready plugins like neural DSP Gojira. Will this be possible with midi guitar in the Future or will there be a m1 native version anytime soon? Im just glad its running for now, but the cpu hit concerns me for bigger projects.

Thank you