Jam Origin

MIDI Guitar & MIDI Bass user forum

Work In MainStage but not in Logic

I’ve got Midi Guitar 2 working great in MainStage, I can play live into it and it plays virtual instruments as expected. However in Logic (on the same computer) when playing a recorded audio track into Midi Guitar 2 I just can’t get it to send anything out to my virtual instruments. The audio shows on the meter next to the noise gate, but nothing registers on the other meter near the velocity / midi controls. I have software monitoring on in Logic. Does anyone have any idea why it’s not working?
Thanks for any help.

@Antiphones
Hello, welcome here!
Have you read this before?
Getting started with MIDI Guitar in your DAW

Yes this is exactly what I followed. I can see the audio coming in (at the meter in the noise gate) but no sound comes out of it and it won’t trigger any synths. I also don’t see an meter reading in the midi velocity meter. I just can’t figure out what I’m doing wrong. I have the plugin loaded on the guitar audio channel with no other plugins on that channel. Here’s a screenshot.

Screen Shot 2020-11-16 at 2.14.00 pm

I am sorry that I cannot help you, I am on Windows pc.
I thought that it could works fine with the video tutorials.
Hope someone will help you.

Sorry, im puzzled, and not sure what to suggest, other than following the video.

Does it work as a pure Audio FX? (if you load a patch inside MG). In this way, if should process audio => audio just like any other Audio FX in logic. Thats a first step.

Assuming that works the question is what’s going on with the midi output from MG and why your Logic isn’t receiving it. Maybe you have it not listening for Virtual MIDI in Logics preferences?

Thanks for your reply. I’ve tired loading it as an audio effect and loading a patch that doesn’t work either. I can see the meter next to the noise gate moving up and down so it’s getting a signal. But no sound comes out. I’ve tried it using Logic on two different machines with the same problem.

Aha. Thats a good lead.
I think this means that your buffersize is too big. If MG gets more than around 6 ms of samples (256 samples at 44/48 khz) from Logic you will see a yellow warning in the MG user interface and MG wont work. This is to avoid people getting huge latency. So you need to double check Logics buffersize and samplerate settings. I guess it could be related to your interface as well, but thats less likely.

Tip: I believe Logic only use the low buffersize when actually recording or monitoring - otherwise it will fall back to a high buffersize which is not working for any kind of live use.

Ah hah! This could well be it. Thank you. I usually have the maximum buffer size set in logic but a very small buffer size in mainstage. I’ll try this out.

Unfortunately that didn’t work. I lowered the buffer to 128 and still no sound. I’ve tried it as an insert on the audio track and on an AUX. I’ve tried loading it’s own internal patches. I can see the signal on the meeter next to the noise gate, but no audio comes out of it. I’ve tried it no two different machines running slightly different versions of Logic and different versions of mac OS. One is a tower and the other is a laptop. So there’s not a lot in common between the two machines.

On the screen shot it looks like you run at 88.2Khz and also that MG warns about the buffersize - while 88.2Khz should work, please try lowering it to 44.1Khz just to rule out any complications from resampling.
Do see those yellow warning signs while recording?

Ok I opened a new empty Logic project at 44.1 I loaded a 44.1 guitar audio file. Buffer 128. I Instantiated Midi Guitar 2 on the guitar audio and loaded one of the standard patches. No audio. Again I can see the audio on the meter next to the noise gate. If I bypass the plugin I hear audio. There is no yellow warning sign now (I had that when I had 1024 buffer size).

On the same machine I played live through MainStage using Midi Guitar 2 triggering a range of different soft synths for several hours without any problems. But as soon as I go to Logic there’s no sound.