App still behaves like the demo version despite purchase [SOLVED]

Yesterday I purchased both Midi Guitar Rig and Midi Output, yet the app still interrupts every few minutes! Here are screenshots to demonstrate this issue…

I would really appreciate you attending to this asap so that I can enjoy what I paid for :wink: Thank you

please restart the app, (go home via home button, swipe up from bottom, swipe MG up out of screen, restart MG).
It should be OK after MG restart.

Thank you Paul, I not only already did that, but also completely uninstalled MG2 and redownloaded it again. The same thing is still happening!

you are sure you aren’t using audio units fx/synths?

It still happens, whether I do or not. Am I missing something here? Is there another in app purchase necessary to be able to use this app as advertised?
Unless I to successfully trigger software synths and samplers outside of MG2, as well as within Garage Band or Cubasis, this app is useless to me.
So far, the app itself appears go be unstable on the latest iPad OS upgrade, and I am only able to use it in a very limited capacity, despite having purchased both upgrades which I was under the impression would be sufficient to unlock these features.
Please sort this out or give me a refund. Thank you.

Your problem is unique: if you start MG without AU’s loaded, you should get no interruptions.
Can you give more details about your ipad? which model is it? how many apps are your running at once?
We had only positive feedback sofar about the last iOS/ipados updates in terms of stability.

Sorry for any inconvenience.

We had an issue in the previous version which was solved in the latest version (2.6.10).
We never managed to reproduce this but the last update (version 2.6.10) should fix any such problems.

Im just writing a PM to you (in this site).

I have been having the same issue since I switched to an iPad Pro 11. Restarting and reinstalling have no affect.

is your new ipad logged in to the same account in the appstore?

Yes, I only have one AppleID and the Shop screen shows that I have purchased everything.

have you tried restarting MG since your last reinstall?

I now seem to have the same issue, oops nope that’s the beta that’s over, sent $$ lol

Ok, lordpreset and DSCB57. We will have a fix as soon as we can understand this.

I seems that for some reason MG doesn’t get to store its settings you your iPads. Something must be special about the way your iPad store the MG data. Its just a tiny file so I assume its not a full storage (although that could explain). So it doesn’t store the information that it was purchased and consequently it interrupts on every new re-launch.

lordpreset, can you help me validate this theory by checking that it doesn’t store which Patch you used in the last session either:

  1. completely close MG (double click home button and swipe it up)
  2. open MG, select a patch (say, “Drawbar Rock”)
  3. completely close MG again.
  4. open MG and please let me know if it has loaded “Drawbar Rock”?

Yes, Drawbar Rock is loaded when I reopen MG.

I am having this issue today on my iphone. Have been an ipad user and desktop user for a couple of years.

Have you tried restoring the purchase in the internal shop and restarting the app after that?

It told me everything was purchased. It was letting me use the virtual midi, which is a paid feature right?

you can use any feature any time, but interruption will come when the appropriate IAP isn’t bought.
If everything is purchased t it but you have interruptions still., please shut down the app and restart it.
( double click home, swip MG up out of screen, restart MG )

Thanks for reporting.
We are submitting an update to Apple today. Hopefully this will address the issue.

I did that a couple of times (the restart). I am not sure if it rectified the problem. I was just trying to test it on my iphone, to see how it performed vs the ipad pro.