Bug: Mostly Black screen - Mg3 beta (3.0.35)

Thanks to let me join the BETA testing phase. I have downloaded and installed MG3. When I open it the GUI is almost empty. I can select my audio input/output. I can also hear my guitar signal through it. All my MIDI input devices are listed and I can select any of them. Whether they “work” I can’t verify yet since there are no VST’s etc. visible at the moment. The program hangs up on closing and must be terminated using “force quit”.

audio IO

1 Like

Thank you for reporting.

That looks like a serious bug on our side… Maybe related to intel/AMD machines. I guess we’ll see more of this and understand what’s going on.

1 Like

Same issue to report here for standalone version only. I’m on an M1 MacBook Air running macOS 14.3.1.

[Side note:I could previously never get the MINI version to render anything in its GUI. Strangely, the MINI version is now working as expected…for the first time ever.]

I thought it might be an issue with registration MG3, since I couldn’t get a license issued via the email prompt in either the Audio Unit or the Standalone version, but the AUv2 version seems to load as expected in Live 12 Beta – but the presets don’t load.

EDIT: registration code just magically arrived but didn’t make any difference.

The MIDI GUITAR virtual MIDI channel crashed mid use in Live. Have to reinstantiate the plugin to get the virtual MIDI back in action.

I got exactly the same behaviour with the standalone version on a Macbook Pro M1 running The last MacOs Release, V14,3,1.
The VST3 and AU plugin versions of MG3 fail during the Plugins analysis of Gig Performer.
I successfully make working the MG3 plugins in StudioOne.
I tried different VSTi plugins with the MG3 midi output generated, but only the MIDI 1 mode is working, not the multi channels mode and not the MPE mode (using Equator2).
Once the MG3 is inserted on a track, StudioOne hangs if I try to remove the MG3 plugin.

1 Like

I made the same experience in Cubase 13 Pro. I can load MG3 as a plugin, but can only use the MIDI output as input for any other VST track. Unloading MG3 or closing Cubase makes it unresponsive and only force quit closes it.

Same issue here with standalone, also crashes on exit:


Model Name: Mac Studio
Model Identifier: Mac14,14
Model Number: MQH63B/A
Chip: Apple M2 Ultra
Total Number of Cores: 24 (16 performance and 8 efficiency)
Memory: 64 GB
OS Sonoma 14.3

Thank you guys. Just letting you know that I’ve tracked down this issue to a problem with MG scanning the audio plugins. Im not sure why it happens and cant reproduce it, but I there is a good chance its fixed in an update within a couple of hours.

No problem With the stand alone. Crashes FL Studio as soon as MG3 is loaded (Vst and AU). The MPE is awesome!

For those of you with a mostly black screen, the new 3.0.36 may fix it.

Nope. Black screen here too (even w/3.0.36).
Mac Retina 5k, 27-inch imac
AMD radeon pro 5500
Ventura 13.5.2

I am having the same issue with Standalone. Running on an M1 Macbook Air.

Same thing here standalone. MacBook Pro M1 running Ventura 13.6.4. Using Beta 3.36…

Thank you for reports everybody. It’s very helpful when you write your hardware and MacOS version.

After 3 hours of sleep tonight, I’ll do all I can to fix this issue.

I still haven’t been able to reproduce it here, on 3 Macs and none close to me have had the issue, so it’s still very difficult for me to track down what’s going on.

  • Hardware: I can’t see any pattern in term of Mac hardware.
  • MacOS: could look like it’s related to new MacOS versions (Ventura or Sonoma). But most people use newer MacOS and most dont have this issue.
  • There is the same underlying issue whether you try the standalone or plugin, as far as I can tell.

My best guess is that it’s related to MG3s scanning of other plugins. I have been able to reproduce a similar black screen, by simulating that some of my plugins will halt the plugin scanning. If my suspicion is right, the black screen actually reacts to some clicks, like the buttons at the bottom left and I can change the BPM… but I can’t load a patch and thus it doesn’t do anything useful. It’s also crashing at exit (force close). Is that what you see?

I’ll make the plugin scanning more explicit and make a new version now, and it will be out later today.

Otherwise the best way to help is to send me your MG3 log file to support@jamorigin.com with subject “black screen”. The log file is here:
~/Library/Group Containers/X6D2Q4W5A8.midiguitargroup/MIDI Guitar Log Standalone.txt
(open Finder, shift-CMD-G, and paste the path).

1 Like

I have exactly the same problem on a Mac M1 Ultra… but not on my M1 MacBook pro?

If my suspicion above is correct, you have some dodgy or incompatible audio-unit plugin installed on the Ultra, but not on the Pro. Could that be?

…and both machines running Sonoma 14.3.1 - the other thing with the black screen is you have to Force Quit… it won’t close

Running a MOTU 1248 on Ultra but tried to open without that running and had same problem?

Yes that could be it… there are very limited plugins on the MacBook book but a lot on the Ultra

I think Ollie already has his head around this but I tested MG3 by changing the path name of the “Plug-Ins” folder in macOS to “Plug-Ins Blocked” to break the registered plugins path. MG3 standalone immediately started operating as expected. Then I reverted to the original folder name and it broke again. It’s definitely plugin related. I guess there around 850-900 plugins on my system after I cleaned up a good 150-200 or so. Good luck figuring out which one/s are causing the problem!

EDIT: Narrowed it down to the “/Components/” folder. MG3 will launch with the regular VST3 path intact. In short, if you rename “/Components” to something else (temporarily of course!), MG3 may launch without a black screen. But there still could be problems with VST3s…that’s beyond my paygrade.

Same problem , this is a Macbook Pro Retina 15 Inch mid 2015 running Monterey I attach the Standalone.tx file
MIDI Guitar Log Standalone.pdf (47.7 KB)