Can't see Midi guitar 2 vst in Studio One 6.6

Hi, I installed the latest version of Midi guit 2 but studio One 6,6 doesn’t see the VST plugin. Just the AU and this one doesn’t pass midi, any idea of how to fix this? Running S 1 6.6 on a MacBook Pro M! MAX, Mac OS Monterrey.

Thanks in advance!

1 Like

Where are you looking? I run SO Pro v6.6.1 on Windows 11 Pro. The MG2 and MB VST2 plugins are listed in the “Jam Origin” folder in the “Effects” tab. MG2 is an effect, not an instrument.

If they are not there, what folders is SO scanning for VSTs and VST3s? It’s been years since I installed MG2 and MB and I don’t remember the default VST installation path. On Windows, most plugin installers default to /Program Files/VSTPlugins/, but some still default to the old /Program Files/Steinberg/VSTPlugins/ folder (which I don’t scan). It might be possible on your Mac that they installed to a folder that you don’t have SO configured to scan.

Hi, thanks for the response!

I’m looking on the effects tab, not the instruments.
I can see it there, but just the au version. I can hide or show the plugins in S1 plugin manager. I can see the only version that shows is the au. Not the vst. I’m following the path that JO shows for Mac installation and I can see the MG VST there with all my other plugins but S1 doesn’t load it. I also refresh the tab to load whatever new installation and nothing. Just one MG that is the au.
I’m on Mac, Monterrey, S1 6.6.
I’m installing the “MACOS 10.15 and newer” file from JO website. So… I don’t know what else to do.

1 Like

If that works, post your success here. Or this maybe, from the PreSonus support website:

If you are running an Apple Silicon Mac (M1, M2, etc.) Mac with Studio One 5.4 or higher and are missing plug-ins, it is possible that your plug-ins are not natively supported on Apple Silicon systems. The following article will give you instructions for running Studio One in Rosetta mode.

Plugins that don’t show up on Apple Silicon Macs

Maybe the JO updates adds Apple Silicon support.

You can also check the plugin blocklist at View >> Plug-In Manager in SO.

Thank you very much The Maartian. But I’m not gonna run S1 in Rosetta mode for only one plugin. So I hope the V3 I’m seeing around will come out soon and will be able to work with M1 that have been around for years now. A little disappointed with JO about this. Thanks again to you!

1 Like

Have you tried posting in the MG3 beta thread and asking if it’s compatible with Apple Silicon? I assume that it is. If so, you can post a request to get access to the beta and get download instructions and a license code by email.

No, I haven’t. I will try that. Thanks!

Installed it. Super buggy and doesn’t pass midi to the instrument track. Annoying and a half all this!
I’ll look for other options. Thanks a lot for the replies TheMaartian! :pray:

1 Like

Have you tried setting up with a “NEW Keyboard”?

Hi, thanks! I don’t want to get lost in a sea of workarounds. I just want midi guitar 2 or 3, to simply work as always: guitar-audio track/plugin-midi to instrument track= sound. When is this gonna be possible with 2 or 3. M1s have been out for years now…

I am not using workarounds as far as I am aware. The setup outlined is the way to get Studio One 6 to work together with MG3 (which is a MPE controller now). I am on an M1 Max, Sonoma 14.5 Mac.

So, is it different now? How do I control an instrument track using MG 3 now. How is the setup or “chain” to do this as simple as possible?

And that doesn’t change that MG 2 vst doesn’t work and MG 3 is still in beta…Sorry but you should have at least a simpler version of 3 already running if you want your plugin to be consider a tool and not a toy!

The way to set up the AU plugin, was in the linked description. I am not Studio One can send MIDI/MPE directly from the VST version simply routed to any instrument track. I didn’t get that to work before, but I am going to give it another try. But since you are on a Mac you might as well use the AU version for now.

You are mistaking me for the developer here, I believe. Was just trying to help.

Thanks, and sorry. Based on the youtube video, I thought you worked for JO. If you don’t, my apologies. As far as I know you could send midi from the vst plugin to instrument track in S1, in Mac, but not with AU. Am I wrong?
I used to do this almost intuitively and I can’t do it now. However is the developer, should be ashamed that the V2 vst doesn’t work on Mac M1, and that the V3 is still in beta. Amazing how companies based on software don’t take responsibility for products they sale these days! This is plugin is not free, for them to do whatever they want as long as they want and leave your customers hanging with beta versions and other versions that don’t work. That’s BS!
And the V3 blinks like crasy right now, the letters ,links and everything…Where is the plugin that I paid for?

I don’t know how Studio One used to work, since I use Logic or Ableton primarily. But I just downloaded the SO6 trial again and ran the standard plugin scan and although I can’t get my old MG2 VST to work here (without Rosetta), I have the old MG2 AU which work like it alway have. And on top of that I have the MG3 AU version, VST3, and VST2 version.
You need to set up by creating a “NEW Keyboard” for any of the AU versions. If you choose the MG3 AU version you also need to check the “use MPE” box. Both of them work fine.

The VSTs versions does not work because Studio One does not have an “OMNI” or “ALL” channel mode to receive MIDI on. The VST versions are sending to track exactly as expected with an MPE controller, using MIDI Channels 2-7. SO is by default set to Ch 1 which would explain why you don’t hear anything at all.

None of this is an MG3 problem. Nor is it a MG2 problem. They are different, in the way they send information.

2 Likes

you are using a product which is clearly marked as a beta version.

if you do not understand the implications of that then you should wait for the first production release.

the product you paid for (mg2) is fully functional in your environment.

no one is ‘leaving anyone hanging’. would you care to retract that comment?

2 Likes

The product I paid for doesn’t even show in my environment! Vst v2 doesn’t shows in S1, Like ALL MY OTHER PLUGINS DO!
The only way is running S1 with Rosetta.
The product I paid for doesn’t exist!
Between tgat V2 that doesn’t work and the beta thing, that I know exactly what is, should be a version tgat properly works! Like every other plugin in every DAW. If JO can’t make that, should quit! Shame on them and shame of whoever supports that BS!

Why not just use the AU?

1 Like

AU doesn’t pass tge midi to the instrument channel. Already said that. And Why!? Do I have to accept tgat vst 2 doesn’t show?
Next time I have a concert I’m not gonna show up, to see how well does that works for me…