Jam Origin

MIDI Guitar & MIDI Bass user forum

Disk overload in ableton 10

I’m getting hard disk overload issues in ableton using the 64 bit vst plugin. i have a high end machine and superfast ssd. i’ve uninstalled and reinstalled multiple times. this solved the problem on a previous machine

most likely the disk overload you mean, is actually “cpu overload”.
If the sound doesn’t break up (crackle), you can ignore such signs mostly.
Please check with the quickstart for how to use MG in LIve.
http://www.jamorigin.com/docs/daw/#toggle-id-1

Most common issues are:

  • Loading synths inside our plugin is deprecated. This will place a big load into 1 CPU thread. Load synths upon other LIve tracks instead.
  • LIve settings audio buffersize shouldnt be too low, the lower it is the more CPU it uses. 256 is normal.
  • On macOS dont use the AU version of MIDI Guitar in Live: it will perform not as good as the VST.
  • Live’s menu: options / “delay compensation” should be off.

Actually, I mean hard disk overload. My CPU never gets over 20 percent. There is a D icon in ableton next to the CPU meter that blinks and is associated with definitive crackles when midi guitar is used to trigger a virtual instrument on a separate track in Live. I have tried multiple different buffer sizes to no avail. My PC is a tenth gen i7 with an ultra fast samsung ssd.

that is strange…
-what is the exact type of your computer?
-does the overload also occur when you havent got a synth loaded on that other track?

Intel nuc windows 10 i7 with 16gb ram and samsung evo 970 500gb ssd. Live 10.

There is no overload when virtual instrument track not loaded.

ok, so the overload is created by the virtual instrument. MG only feeds midi notes to it, plus bends and aftertouch when they are enabled.
there are some plugins that are allergic to bend info, but that is a rare case.
What virtual instrument do you use?

I’ve tried a bunch of different ableton instruments including grand piano and strings/cello. It’s very strange because I had the same problem on a different i7 machine 2 weeks ago and it went away after I reinstalled the midi guitar plugin (or at least I think the reinstall fixed it. It could have been some other tweek I made)

disk activity is often “swapping” which happens when physical memory is full: the current job is then saved on disk, the new job fetched from disk in a endless motion, making it overload…
Browsers can use notorious amount of ram, so allways try close your browser when you encounter such problems.
Further the issue: Live’s menu: options / “delay compensation” should be off
is often forgotten.
it is unlikely that it is ASIO driver related: this wouldnt result in disk swapping.

I’ll try again tonight. Delay compensation is switched off. Maybe I need more ram, but the problem also happens when I start with an empty project with 1 midi instrument and 1 audio track for the plugin.

what is the type and name of your computer? intel nuc? or is that the mainboard type?

Intel nuc is the name.

ah, ok, that is a barebone system.
In that case there is not much else to check than the audio driver settings.
Which interface do you use? if you use your onboard audio with ASIO, it will give a conflict with your system audio; they will both try claim the complete device.

Asio with scarlett 18i20

ok, heard about setup problems with that interface before. So it is probably an interface problem: ASIO and/or firmware.

Ok. Thanks. I’ll check all that tonight.

ok, good luck!

                                           .

I also had the same problem with brand new motu on the other machine though.

same type of machine?

No. Brand new surface pro i7 with 16gb ram and 250gb ssd.

mmh… this all points to a default Live setting that is unfavourable… what is your exact Live version?