Jam Origin

MIDI Guitar & MIDI Bass user forum

Is it Silicon compatible?

Is it compatible with Silicon Mac M1 Studio OS 12.3.1?

Hi @NorthTower
Totally anecdotal, yes, but I have MG2 (MIDI Guitar 2.2.1) running on all three of my Macs (one being a M1), and I can’t see any difference in function and behavior (yet?). There seems to be somewhat conflicting information on the forum in terms of second hand reports, someone referencing someone else’s experiences, where for instance the MINIMAL plugin was developed for those M1 users reporting having had “problems with MIDI Guitar 2.2.1”.New plugin: "MIDI Guitar Minimal" for Mac / BigSur But whereas the MINI seemed to have run into some problems with rosetta (as reported by @Vaultnaemsae) MG M1 native version for Ableton 11 - #3 by Vaultnaemsae, there seems to be no real issues reported with using your regular MG2 in OS 12.3.1 as I am right now. But let’s hope, instead, for those actually having had issues to be reporting on those here. That would be way more useful than any singular positive review, even if you are looking for evidence for compatibility.

I came back to this today since LoFiLeiF said he had it working on his M1 Mac.

I dropped the mini app in the applications folder and opened the package to show contents. In the “Contents” folder there is a file named “embedded.provisionprofile” which I launched and then was given an option to install it. See pics below.

After doing this the AUV3 works in Logic (native – probably Rosetta 2 also but I didn’t test) but it doesn’t work in Live 11.1.5.

The standalone app still doesn’t work correctly. I’ve tried resizing the window as suggested in another post without success.

Actually, what I really need to know is that it is fully compatible with MOTU Digital Performer 11.1 on My Silicon Mac M1 12.3.1.

Hey Luke!

Just to be clear. I am only using the standard MG2 plugin (MG2.2.1). I referenced the MINI plugin issues as well, but I haven’t installed it on my M1. I tested it for its MPE functions on my old Intel setup though. Do you have any issues with the (standard) MG2.2.1 setup on your M1 @Vaultnaemsae?

MG2 works fine on my intel Mac running Monterey.
The only issue is the weird rendering in the plug-in menu left-side column.

1 Like