Midi Guitar 2 not working on Studio One 6

I am trying to get Midi Guitar 2 to work in SO 6 and a M1 Mac Mini 2020. I have followed the following steps and even through I get a signal from the guitar on TRK 1, and the Midi Guitar 2 configuration screen shows that signal is nicely being converted to midi. But it is NOT being routed to TRK 2 and therefore the synth instrument is not getting triggered. Here are the steps I followed which worked for the OP. "On the Home Page click New and choose Record and Mix for a new blank song.

  1. As per the article: Add a mono audio track for your guitar, and assign its input to your guitar’s audio interface input. Set the track’s input Monitor to on.

  2. Check you have input before the next step, may save time later and confirms that you do have input, the meter will also confirm this, but once you add the MG2 plugin it goes silent unless you use MG2 as the instrument and we are not doing that, a different tutorial.

  3. Insert the Jam Origin MIDI Guitar 2 plug-in into the guitar track.

  4. You will find this in the browser under Effects - Vendor - Jam Origin.

  5. Also under Type - AudioUnits.

  6. Just drag the icon across onto the left hand box on the guitar track you just created.

  7. Silence! The audio is not passing through now, but don’t worry we want the Instrument sound.

  8. Create an instrument track with your instrument of choice. Mai Tai is my go-to for MIDI guitar, but any VST3 or VST2 instrument I’ve used so far works.

  9. For me Presence or Ample Bass and for Mike Mojito.

  10. Vital - Do this by going to Instruments in the browser and drag the icon of your choice into the Track window, not the Mixer window as this does something different and will be investigated later.

  11. This is where it gets tricky as the article says : Assign the instrument track input to MIDIGuitar2-64bit (fig. 1).

  12. It leaves vital info out so follow what I did and hopefully it will work for you.

  13. Things have changed in Studio One 6 and if you have followed me exactly you will see your guitar track and instrument in the Track Window in Normal View, I recommend that you also open the Mixer Window .

  14. In Studio One 5 I would normally click the ‘i’ above the tracks on the left to open Information and use this to assign the input, this is now missing in Studio One 6 so what do we do next!

  15. Change the Track view from Normal to Large and you will see the all the options, it will show All Inputs the second one down, we need MG2 as input,. The problem is this does not work for me so I had to try something else.

  16. Open up Preferences, I click I/O top left of the Mixer Panel and you get Song Setup, click Preferences bottom left and then External Devices.

  17. Now we need to add MG2 as an External Device so click Add.

  18. A new window will open up to add a New Keyboard.

  19. I entered ‘Jam Origin’ as the Manufacturer and ’MIDI Guitar 2 Ext Inst’ in Device Name.

  20. In the Receive From further down choose ‘MIDI Guitar # ‘x’ out’, I was showing #2 as I have already done this once.

  21. Go back to the inputs on the Instrument Track and try again, you will now see ‘MIDI Guitar 2 Ext Inst’ as an input option.

  22. Choose this and it all worked for me.

  23. Make sure that the Loudspeaker icons are activated to hear everything.

Has anyone been successful?

It seems that SO 6 on a M1 Mac Mini 202 Ventura does not support VST 1 anymore since the only plugins that show up are all AU, VST 2 or VST 3. And since AU apparently doesnt transmit midi data, it seems that Midi Guitar 2 will NOT work with Studio One 6 on an M1 Mac Ventura ( since the only plugs they provide are AU and VST). Dont waste your time.

MIDI Guitar is not a VST1. It comes as a VST2 and AU2 - both supported by Studio One.

My best guess is that somewhere is an incompatibility when using the Apple Silicon version of Studio One 6, to host x64 plugins under Rosetta.

Well it maybe VST2 but Studio One will not load it, but does load the AU version… AU is not even a consideration since it is documented (by Ableton coder) it does not transmit midi in M1 Ventura.

The problem is the VSTs are in the correct folder area (left) but do not show up as plugins in Studio One (right) Just the AU ones are loaded. But they dont transmit Midi data on M1 systems.

I had some issue with getting MIDI Guitar 2 to show up as a VST in Abelton while I was still using rosetta. Once I stopped I had no more issues. But the AU has always transmitted MIDI on my M1 system. Are you saying it is an M1 problem or a Ventura problem?

The problem is with the Midi Guitar 2 VST2 plugin. It ONLY shows up when I boot Studio One 6 in Rosetta mode. When I boot it up normally the VST is not there. And their AU version is useless on the M1 Mac since it doesnt transmit midi data. So “bye bye” Midi Guitar 2. Such a shame.

We’ll investigate this.

MG has worked with Studio One for Mac for a decade, and nothing changed on our side for several years. But sometimes we see DAW updates unintentionally break things, and fixing it again in another update, as they become aware.

Apple Silicon has shaken things up a bit and of course we’ll make sure it all works. MGv3 will be Apple Silcon native, as is the MINI version that was intended as a temporary workaround until MGv3 is out.

There is some misinformation in your comments (VST1, MG AU doesn’t send out MIDI), but thanks for editing it.

Sorry, but based on my extensive testing, AU plugins DO NOT send midi information.

This has also been experienced by others. This is a post from Ableton tech support.

https://help.ableton.com/hc/en-us/articles/209068929-Using-AU-and-VST-plug-ins-on-Mac.

" * AU plug-ins do not support a direct MIDI out. If you wish to route MIDI from a plug-in you need to use the VST version instead. See this article for info on how to access the MIDI outputs of a plug-in."

So, I downloaded the SO6 Demo to my Mac Studio 2022 (although only still on Monterey 12.5.1) and had no problem with the AU MIDI being sent and received to a software instrument track.
Skärmavbild 2022-12-14 kl. 13.47.01


Just like with Abelton though no VSTs are available without Rosetta. (I was confused with my earlier description) I had to recheck my settings and it turned out it was the other way around. Sorry about that! But I can’t find any issue here for now. What does your MIDI Monitor window look like when you play?

1 Like

I have found some time to test and also found this thread, I can assure you that the AU version does work in S1 v6, however it does need to be set up correctly using the add new keyboard in preferences. The VST version is easier as the MG2 will show up in the input menu.

The easiest way is to use the plugin instrument within MG2, although I must admit that I do tend to use a separate channel as it is more flexible.



If you get stuck, I am rushing this, try me again later, sorry I have a jam to get to.

A copy of my earlier reply:

You have not said whether you actually got it to work and OS, etc.

Time flies when you are enjoying yourself and the above exercise has blurred into obscurity so I have just checked out a few details.

My Mac M1 is currently running Ventura 13.0.1 and S1 v6.0.1.90430 macOS x64 (Built on Nov 8 2022).

Yes you do have to run S1 in Rosetta, frustrating, however I have not noticed any difference in performance for my projects, usually only about six tracks for live work.

The only problem was me accepting it as it felt like I had just bought 3.5 litre car and was being forced to run it in economy mode at 350cc. :upside_down_face:

I will try the AU version later to check out the no midi problem as time is against me this morning.

Midi flow is indicated in the MG2 app, but is not transmitted by the AU plug in. This is what Ableton Tech Support says about AU plugins.

" When used on an Apple Silicon computer, the Universal build of Live 11.1 only recognises VST2 and VST3 plug-ins natively compiled for Apple Silicon. Please note that some specific AU involve Intel-compiled processes, and that these will require Live to be run as an intel application via Rosetta 2. You can find more information here."

Thanks for the screens but they are illegible. I gave a detailed account of how I set up the AU plugin to be used. Please read it to determine if you have done anything differently. Thanks!

I believe that the procedure you are referring to starts with #16 in my original post.

I must be missing something here, but I just recorded the blue Trk 2 part, with Pitch bend and AT MIDI clearly showing. I set up the MIDI out from the JO MG2 AU as a “New Keyboard”, pressed REC and Monitoring for both channels/tracks, and pressed Record. I have also tried driving both the Pianoteq and the SEM together by just having monitoring checked for both. It worked fine! Is there some special setup or use for MG2 you are referring to that I am missing perhaps?

Hi. I replied to your similar thread over on the VguitarForums: Midi Guitar 2 will NOT work with Studio One 6 on an M1 Mac Ventura

One thing that you didn’t mention (and that would be useful to know) is whether or not you had the same software setup working on macOS Monterey previously.

Thanks. Yes, I just got it to work. In Studio One 6 I dragged the instrument (Analog Lab 5) to the track area instead of the left (mixer area) and that fixed it.

Glad to hear that you have fixed this now.

You may have missed it as there was so much info to take in, step 10 does say this is vital now, it through me for a while because I was certain that the drag to the mixer area used to work sometime in the past.

Enjoy

1 Like